Buy Now
Sign in

You didn't pass the NoCaptcha verification.

lnemecj , August 11 2017
Answered
lnemecj
Hi,
In Chronoforms v5 and v6 security check (NoCaptcha) stopped working. In version 5, I solved this problem by changing the "Relative URL" value in "HTML (Render Form)" from Yes to No. In version 6, however, this feature is not. Don't you know how can I solve this problem?

Thanks,
Lada

- The form is fill corectly. NoCaptcha field is also checked green.
- All Chronoforms and ReCaptcha plugins are enabled.
- Secret and site key is inserted (In Chronoforms and also in plugin Captcha - ReCaptcha).
- No updates available.

PS: website is using SSL and v5 and v6 are instaled at the same time.

Debugger:
Array
(
[google_nocaptcha8] => Array
(
[response] => Array
(
[success] =>
[error-codes] => Array
(
[0] => missing-input-response
)
)
[_error] => The NoCaptcha verification has failed.
[var] =>
)
)
T
tonydoe
Hi there!
I happen to have the same problem with one of many installations of CFv5 (5.0.16). Although the majority of my CFv5 installations work just fine, this particular one has stopped working recently, returning a security check error message every time a user tries to submit a form. The form itself is set properly just like on my other sites. ReCaptcha keys are also set correctly and recapctha widget gets checked green which means the problem is somewhere else.

The faulty insttallation is located on a separate hosting server, below are some specs:
PHP Built On  Linux kitty 3.16.0-4-amd64 #1 SMP Debian 3.16.43-2+deb8u3 (2017-08-15) x86_64
Database Version  5.6.37-82.2-log
Database Collation  utf8_general_ci
Database Connection Collation  utf8mb4_general_ci
PHP Version  5.6.30-0+deb8u1
Web Server  nginx/1.13.6
WebServer to PHP Interface  fpm-fcgi
Joomla! Version  Joomla! 3.8.1 Stable [ Amani ] 4-October-2017 14:00 GMT
Joomla! Platform Version  Joomla Platform 13.1.0 Stable [ Curiosity ] 24-Apr-2013 00:00 GMT


The solution suggested by Inemecj ( changing the "Relative URL" value in "HTML (Render Form)" from Yes to No) unfortunately doesn't work for me.
Do you have any idea what is wrong?
admin
Hi tony,

What does the debug show ?

Best regards
Max
If your main question got answered then please mark the answer using the button!​
​Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
T
tonydoe
"admin":
Hi tony,

What does the debug show ?

Best regards


Data Array
Array
(
[option] => com_chronoforms5
[chronoform] => order3
[event] => submit
[text1] => test
[text2] => 12345678
[text5] =>
[textarea3] =>
[g-recaptcha-response] => 03AHhf_50POIS4mtXB0HggHsAK-5ZBCNs_DbY_-UjaIkXom6t-gu-XyBai9tc2wCGrDwtod2-gcBoB7qoGqDp2CgoUkBfN1LSPnBBCDqlUdsIrQNvgtTvpMPNcJLIfJRK8O5Epc3iwGbeM2i4AFtuq2y-lyErONrVHcss5-KtFsgnFzrYQKFegFXtUeOVsrUxJpQsIjMedTF9-VJmXnKIfz4OTMyROJ4pJ2r17SX2bpG4NsTHjKSeJkR23RJUe791SmEBFWWV0ZbPwaZOp16I1xTNXzLACPDTvWYVYuZLgCpk6UWAI2hPes9w_epmF97Ce-RiEdZIv-lC4MP_vEI-BIJLlWgsG1COUk9fH9VdprBi2hiPOyc7NPnFRkfT5TeNHptuGu-VT4767RN_5VvipOQVf_m0W04TBKQ
[checkbox9] => 1
[button6] => Отправить заявку
)
Array
(
)
Errors
Array
(
[recaptcha] => Вы не прошли анти-спам проверку!
)
Debug Info
Array
(
[15] => Array
(
[Check Google NoCaptcha] => Array
(
[0] =>
)

)

)
T
tonydoe
I got the above after placing a Debugger instead of Event Loop inside of the Fail event of the Check Google NoCapthca action. Hope this is done right.
T
tonydoe
Data Array
Array
(
[option] => com_chronoforms5
[chronoform] => order3
[event] => submit
[text1] => test
[text2] => 12345678
[text5] =>
[textarea3] =>
[g-recaptcha-response] => 03AHhf_50POIS4mtXB0HggHsAK-5ZBCNs_DbY_-UjaIkXom6t-gu-XyBai9tc2wCGrDwtod2-gcBoB7qoGqDp2CgoUkBfN1LSPnBBCDqlUdsIrQNvgtTvpMPNcJLIfJRK8O5Epc3iwGbeM2i4AFtuq2y-lyErONrVHcss5-KtFsgnFzrYQKFegFXtUeOVsrUxJpQsIjMedTF9-VJmXnKIfz4OTMyROJ4pJ2r17SX2bpG4NsTHjKSeJkR23RJUe791SmEBFWWV0ZbPwaZOp16I1xTNXzLACPDTvWYVYuZLgCpk6UWAI2hPes9w_epmF97Ce-RiEdZIv-lC4MP_vEI-BIJLlWgsG1COUk9fH9VdprBi2hiPOyc7NPnFRkfT5TeNHptuGu-VT4767RN_5VvipOQVf_m0W04TBKQ
[checkbox9] => 1
[button6] => Отправить заявку
)
Array
(
)
Errors
Array
(
[recaptcha] => Вы не прошли анти-спам проверку!
)
Debug Info
Array
(
[15] => Array
(
[Check Google NoCaptcha] => Array
(
[0] =>
)

)

)
admin
Hi tonydoe,

v5 debug does not show all the info like v6, please test on v6, you can install v6 beside v5 on the same website!

Best regards
Max
If your main question got answered then please mark the answer using the button!​
​Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
M
mirtech
Hello,​
​I had exactly same problem with NoCaptcha verification on one of my site.

​Issue was, that file_get_contents function (line 29 – check_nocaptcha.php) was not working. ​
​I have replaced that with curl function.

​Another option is to allow allow_url_fopen=on in php.ini (didn’t try that, but that was another suggestion by researching this issue).​
​​
​I hope that this helps someone as I think lots of chronoform users will have this issue after Google re-captcha V1 will stop working at the end of March.​
​​
​Cheers,​
​​
​Miroslav​