Buy Now
Sign in

Cant see Submit button ?!

pcpro , June 01 2015
p
pcpro

I added the submit button, but its not visible in the form on my site ..!?

GreyHead

Hi pcpro,

I've no idea :-( Please post a link to the form so I can take a quick look.

Bob

ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much

p
p
pcpro

Now, I installed Chronoforms instead.
And the plugin

Well, the link to ypur site shovs, but not the form...
http://gourmetakademien.se/lunch

GreyHead

Hi Pcpro,

You need to add an HTML (Render form) action in the form On Load event. (Please see this FAQ)

I've done this for you and added a Debugger to the On Submit event so that you can see the data being submitted. You will need to add other actions to send an email / save the data, etc. and disable the Debugger before going live.

Bob

ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much

p
pcpro

Thanks, but there is still sme issues.

First , the fields have contant, (which I thought would be good,)
But the text doesnt go away when someone starts writing something, they have to maually erase it.
So I want the fields emty.
And I go to the Designer tab, and change that, and save it.
But there is no chage at all in the visible form on the site !

Also the text labels shows "text label" for Name and Telefon.
That cant be changed eather....

The calendar has 35 days ???
As far as I know there isnt more than 31 days in the longest months...
And what is NAN-NAN-NAN- NAN ?
I cant even pick a date..... not working !

I dont understand what to get from the debugger, I see no difference if I enable or disabe it.

p
pcpro

Why cant I edit my own posts... ??

GreyHead

Hi pcpro,

Why cant I edit my own posts... ?? because we have and a lot of spammers who make posts that look OK and then come back later and edit them to add lots of links.

So I want the fields emty. I just checked and they are empty. If you add a Value that needs to be edited; if you add a Place Holder label that will go when the user clicks in the box.

But there is no chage at all in the visible form on the site ! I don't know what that means?

Also the text labels shows "text label" for Name and Telefon It looks as though you have now found how to do this? You need to replace the default text label with Name.

At present the Datepicker is not working because you have set a start date of 1 and an end date of 31. As the text under the boxes says "The start date in the same format set for the picker."

Bob





ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much

p
pcpro

Ok,

For the changes I made, just some of them gets saved it seems.
And for those that gets saved, it takes a long time before I coukd see the change in Front End..
Yes I know F5, and that didnt help.

For example, I removed The Field value for all elements.
And now after half an hour, I can see any change..
Except for the second one (Telefon), that didnt change for 45 minutes...,.

I have a fast line, and the server is at hostgator.com, I have never had any problems like this there before.

About the datepicker, I changed 1-31 AFTER i found out it chowed 35 days in a month.
I dont understand what "The start date in the same format set for the picker." means !
And What about NAN-NAN-NAN ?

As you see on the site, the text message field is to wide.
Can that be changed, or responsive ?

p
pcpro

Where do I set up to what email address each forms go ?

In Edit action, shouldnt "Form method" be "Post" to send mails ?

p
pcpro

Excatlly Now at 16:00 my time, I chaged all labels positions to Top.
Lets see how long it takes for me to see any change...

p
pcpro

At 16:11 I also removed the 1- 31 days in datepicker.
No, change in Front end

And there are still no changes in Front End of the labels I changed 10 minutes ago ...

p
pcpro

At 16:18 I can see the changes I made at 16:00
And now the calendar also works and show the right dates !

p
pcpro

Why does this happen ?

Now I still have the issue that tje fields are to wide, especially the Message field.
How do I solve that ?

And where do I set to what email address each form send mail ?
I need at least 3 different mail forms with 3 different mail addresses to be sent to..

It seems that php mail doesnt work.
So at the moment I use smtp mail in Joomla settings.
That s not optimal...
Any idea why php mail doent work ?

p
pcpro

At the Forms Manager , there is One Issue ??
What is that ?
I cant click anywhere to see what it means ...

GreyHead

Hi pcpro,

Emails are working correctly from your site

The Form Issue is that the Debugger in your form is disabled - that's not an issue, just information. You couldn't see it because you had switched the form from Advanced mode to Simple mode.

The text area width is the default 40 columns, you can change the column setting or use CSS to over-ride it,

The same with the input widths,you can use BootStrap classes or CSS to set different widths.

Bob

ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much

p
pcpro

The forms has no purpose if no mail is sent...
This is an urgent issue.

GreyHead

Hi pcpro,

I'm not clear what the problem is? As I said, emails are working correctly from your site. You do need to add and set up an Email action in your form though. This video may help.

Bob

ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much

p
pcpro

I now copied one of the demo forms instead and try to modify it for my needs.
Making one from scratch seems not working for me...

Using he modified "contact form captha" works, but only to get a copy of the sent email.

There is some strange bug in sending mails from my site, because the maiserver is at another host.
So I found out that php, and sendmail dont work, but smtp works. So can that be set in Chronoforms ?

p
pcpro

In my own form I tried to make two email actions, one for sending a copy of the mail to the sender, and one for sending the actual mail to me.

I get an error at "View Form" that no recipient email adress is provided".
But the recipients email is not known to me, can be anyone....
I guess I should use dynamic, but I cant figure out what to fill in for that to work ...

And sending a mail to me doesnt work, because the form uses php mail