Buy Now
Sign in

Joomla 3.3, Chronoforms V5.0 RC6, V4 forms - missing PHP

adrian99 , May 05 2014, 17:41
A
adrian99 10
May 05 2014, 17:41 #329868
I upgraded Joomla to 3.3. Then the Chronoforms administrator page went completely blank. I found a forum entry that said I should use Chronoforms 5.0. So now I have installed that, but I cannot get my form to work.

My form was developed using Chronoforms v4 under Joomla 2.5. I took a backup from there and restored it to Chronoforms 5.0 using the experimental v4 restorer.

When the form is selected on the front end, the following messages appear:
PHP Fatal error: require_once(): Failed opening required '/home/sites/xxxxxxxxx.xxx/public_html/newlayout/administrator/components/com_chronoforms/versions/j3.3/admin.chronoforms.php' (include_path='.:/usr/share/pear53:/usr/share/php:/usr/share/ZendFramework') in /home/sites/xxxxxxxxx.xxx/public_html/newlayout/administrator/components/com_chronoforms/admin.chronoforms.php on line 19
PHP Warning: require_once(/home/sites/xxxxxxxxxxxxxx.xxx/public_html/newlayout/administrator/components/com_chronoforms/versions/j3.3/admin.chronoforms.php): failed to open stream: No such file or directory in /home/sites/xxxxxxxxx.xxx/public_html/newlayout/administrator/components/com_chronoforms/admin.chronoforms.php on line 19


Now I am completely stuck. I have developed many complex forms in Joomla 2.5 which I need to migrate. On the latest Joomla, I have no choice but to use Chronoforms 5.5. But I have no way to run all my forms.

Please help!
admin 28
May 06 2014, 05:33 #329881
Hi adrian,

No need to go to v5 now, just download the latest v4 installer for J3, its available on the downloads page, then install it OVER yours and it should fix the issue!

Regards,
Max
Max
If your main question got answered then please mark the answer using the button!
Did you try the new ChronoForms7 ? if yes then please send us your comments!!
GreyHead 64
May 06 2014, 07:32 #329896
 1
HI adrian99,

Please upgrade to the latest release of ChronoForms v4 for Joomla! 3.

If this happens again and there is no new release then you can usually get round it by copying the most recent administrator/components/com_chronoforms/versions/???/ folder and renaming it to the new release number. In this case that would be from j3.2 to j3,3

Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
A
adrian99 10
May 06 2014, 19:47 #329938
That fixed it.

Many thanks.
D
doromi 96
May 22 2014, 08:03 #330773
THANKS, Bob,

that did the trick for my Joomla 3.3 as well !

doromi
P
poojathakur 2
May 30 2014, 09:35 #331158
I am new to chronoform....is this chronoform is compatible with joomla 3.3??? and what is this validation key how we get it?? is it not possible to use the chonoform without validation key??
GreyHead 64
May 30 2014, 10:25 #331166
 1
Hi poojathakur,

Yes ChronoForms v4 and v5 are both compatible with Joomla! 3.3

Please see this FAQ about validation.

Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
P
poojathakur 2
May 31 2014, 11:57 #331232
Thanks Bob,
I need more help from you. Will you please send me a tutorial about the working of ChronoForm. I am not getting that how to create database of these forms.
Thank you
Pooja
GreyHead 64
May 31 2014, 14:01 #331234
Hi poojathakur,

There's a video for CFV4 linked from this FAQ. If you are using CFv5 it is more or less the same.
Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much