Buy Now
Sign in

Editable fields in the listing CC v5

warmbeach , March 08 2014, 04:10
W
warmbeach 19
March 08 2014, 04:10 #326096
Hi,

Is it possible to have editable fields in the listing of CC V5? Just like what CC v4 Data Listing Fields used to do.
I tried adding article.title:return '<input type="text" name='.($cell).' value='.($cell).'>;
in the "PHP Function" box. It lets me edit the value but it doesn't save using the _TOOLBAR_SAVELIST_ button...

Can somebody help me with this project?

Thank you!
admin 27
March 19 2014, 05:43 #326871
Hi Dan,

I have a tutorial on this feature, still need to publish it though, so please give me 1 or 2 days!

Regards,
Max
Max
If your main question got answered then please mark the answer using the button!
Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
W
warmbeach 19
March 19 2014, 16:35 #326931
Thanks, Max.

I'm looking forward to it!
admin 27
March 25 2014, 13:40 #327325
 Answer
Just added!
http://www.chronoengine.com/faqs/72-ccv5/5213-direct-list-editing.html
Max
If your main question got answered then please mark the answer using the button!
Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
W
warmbeach 19
March 25 2014, 19:56 #327350
Thanks so much, Max!
Works like a charm!
W
warmbeach 19
April 16 2014, 22:33 #328921
Hi Max,

Quick question, how can I get this feature to work for associated model's fields? Model_id[primary_key][field_name] for the field name doesn't seem to be working (keeps getting the error "Save Failed"). Does it need a different format or something?

Thank you,
Jo
admin 27
April 17 2014, 12:34 #328957
Hi Jo,

I'm not sure if this will work but please try to set the "associated save" to yes under the model settings and check if it works.

Regards,
Max
Max
If your main question got answered then please mark the answer using the button!
Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
W
warmbeach 19
April 17 2014, 17:05 #328979
Thanks, Max, for responding.
It doesn't work with the "associated save" either...
admin 27
April 17 2014, 20:16 #328984
What's the relation between the associated model and the main one ?

it should NOT be "BelongsTo" in order for the associated save to work, since this means that the main model is a secondary model and it should not update the primary one (in the relation).
Max
If your main question got answered then please mark the answer using the button!
Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
W
warmbeach 19
April 17 2014, 21:49 #328993
It is "Belongs To", but I can't get it to work with any other relation type. Your explanation helps, now I just need to figure out how to get it to work with the "hasMany" or "hasOne" relation type, what's the difference?

THanks, Max.
admin 27
April 17 2014, 22:14 #328994
When you set it to "hasOne", does everything else work fine ? like the listing, editing..etc ?

Regards,
Max
Max
If your main question got answered then please mark the answer using the button!
Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
W
warmbeach 19
April 17 2014, 22:25 #328995
I got it to display the associated model values with "hasOne", but direct listing editing still doesn't work.