Buy Now
Sign in

ChronoEngine Product Application Engineer Wanted

RLaurel , February 04 2014
R
RLaurel
After 90 days of trying with several people, we have failed to make a working complex ChronoForms query which works to read information from a MySQLi database. I can either make the 9 criteria search form without a ability to make the joins work to the between the 5 tables or I can get ChronoConnectivity to make all the joins work without having a search form at all.

We need someone who can make ChronoForms work & write the custom PHP code necessary.

Who can do this & at what cost?
admin
Hi RLaurel,

Please post the project's info or a link to it if it was posted before, I can give you some hints of how to build tables joins in v5, this is so easy and will take no almost no time, but you will have to use v5 of course.

Regards,
Max
Max
If your main question got answered then please mark the answer using the button!​
​Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
R
RLaurel
Pardon my ignorance!
I understand I need at least one of these. But which one?

Why would I need to install the ChronoEngine version 5 component?
Why would I need to install the ChonoEngine version 5 module?
Why would I need to install the ChonoEngine version 5 plugin?

We are migrating from Joomla! 1.5, (which works very well), to Joomla! 2.5 or Joomla! 3.x. We have been going through the agony of this conversion because we know we must!

I will be delighted to post the project specifics. I just need some assurance that this is not in a public forum or a private communication. It is not that there are any big secrets, it is just to access the search or administration of the website, is limited.

Thanks in advance,
Roger
admin
Hi Roger,

That's a public forum, no info should be posted here, except general stuff.

I just need to know what you are trying to do with the tables joins, which tables are joined together and their names, I can then write a demo code for you, don't post any login details or links.

Regards,
Max
Max
If your main question got answered then please mark the answer using the button!​
​Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
R
RLaurel
I have installed ChronoForms version 5 Component, Module & Plugin successfully.
I have enabled the ChronoForms version 5 Module & Plugin. I see the forms I have been working with in both CF & CC. As I said, I have been using both products in an attempts to get them to work with desired results.

I have never understood the difference between a component, module & plugin. The installation process, because it is an installation of 3 different code pieces, appears that I may not need all of them. But, I am too ignorant about it to understand.

No URLs, accounts or password/passphrases will be posted here.

I have this much working in CF, a 5 table join with a result set of the entire database. I am trying to write a search form with 9 input areas where a user may conduct a more targeted search. It is expected that a users may only put in 2 search criteria, but in as many as 9 inputs. But none returns the entire data set.
R
RLaurel
Perhaps I should PM you some of the failed efforts I have made.

I feel I am close because I get it work in limited ways. I seem to be missing some small feature.
R
RLaurel
What I am attempting is when invoked, I have a search form at the top half of the screen & a partial data output of a 3200+ row database in the lower half of the screen.

In one attempt in , I have ChronoConnectivity working with all joins. But there is no search form.
In another attempt, I have a ChronoForms produce a search form, but there is no data output what so ever, however the table column labels show. When I put in a value & search, the column titles disappear but still no data result.
In a third attempt, I have a ChronoForms produce a search form and data output, but the joins to the other 4 tables are not complete. Only the key values show. Again, I am unable to search any of the data. When I do input a search value & search then all data out put disappears from the screen. Yet I know the string to be there, for I witness it on screen before input it.
In the fourth has failed attempt I have an Access Denied problem. I think I was just mentally exhausted when this one failed & I had forgotten I was able to achieve in the other 3 attempts.

How can I deliver this so you can see?
R
RLaurel
I didn't say it above. The fourth attempt was a ChonoConnectivity attempt.
admin
Hi Roger,

Apologies for the delay!

I suggest that you give it a try with the new v5, it should do what you need easily, if you have any questions then please send them to me, and if you can't get it to work then I can help you to get it done!

Regards,
Max
Max
If your main question got answered then please mark the answer using the button!​
​Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
R
RLaurel
Of the 4 approaches I have tried above, which one has the most promise? I will try again in version 5, so I need to make the forms in that version or tweak the one which partially works.

Can Forms created in earlier versions be inported into this version?
admin
You only need to search and list, so you will only use Connectivity, you will have to rebuild the connection because v5 is different, no need to uninstall v4, keep your work intact, v5 can work beside it.

The tutorials should make everything easy, but it doesn't explain how to make the search, this is explained in the connection settings area itself under the "searchable" box

Regards,
Max
Max
If your main question got answered then please mark the answer using the button!​
​Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
R
RLaurel
1st. I like the new look of the CE fourms.
2nd. There is a broken link to the download for ChronoConnectivity on the home page. (404 error)
3rd. If it is thought that ChronoConnectivity holds the most promise for my issue, it is not available in version 5. CF is!
4th. I have installed CF Component ver. 5.0 RC4.1; Module V5 RC1.2 & Plugin ver. 5.0
5th. I have installed CC Component ver. 4.0 RC3.2
6th. If CC has the best chance, what should I do in CF v5?

I am confused!
admin
Hi Roger,

Ofcourse cc has v5, here its:
http://www.chronoengine.com/downloads/chronoconnectivity.html

Please install it and check the ccv5 tutorials section under the FAQs page!

Regards,
Max
Max
If your main question got answered then please mark the answer using the button!​
​Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
R
RLaurel
Thank you! I got CC version 5 & validated it.

1. The CE home page still has a broken link to CC download. (http://chronoengine.com/downloads/7-chronoconnectivity.html)
2. As the web page copy reads, if it were working, it would link to CC V4.0 RC3.2

I am hoping to backup my CC & CF forms made in V4.0, restore them individually to CC & CF V5.0 & remake the database connections.

I am hoping not to recreate each & every CC & CF form I have; just 'massage' them a little.

Am I thinking clearly?
R
RLaurel
Apparently not!

The back made of one CC form went to the downloads area specified by my browser.

The restoration from that download, produced a "Restore error" in CC V5.0.

Looks like I must recreate all the CC forms. I wonder if this process will work for CF forms?
GreyHead
Hi RLaurel,

Please use the DownLoads page to get the latest versions (I suspect that the Homepage link may have been broken when the site was upgraded to Joomla! 3).

I know that the Back-up + Restore route between CFv4 and CFv5 is experimental and doesn't work for all forms; I didn't know that there was any similar path for CC.

Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
admin
Hi,

For a list and search, you only need CC, no need for forms, you can also keep v4 and just install v5 with it to experiment, both can be installed on the same system at the same time, the tutorials should help you build a list using v5 quickly, after that you can post any questions here.

Regards,
Max
Max
If your main question got answered then please mark the answer using the button!​
​Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
R
RLaurel
OK, I have a new member query form in CCv5. When I have more than one model, (there are 5 table joins I will need), I have a blank white page output. (Debug is set to "Yes")

When I have a CCv5 member query form with one model, I have an output on the screen of the column headings I will want & a SELECT statement with many AS assemblages where the model & column names have been combined. I realize this is where I am building my WHERE statements & for a single model, this WILL NOT work, but at least I have a screen output.

My Joomla! Database is running the InnoDB engine.

I have looked over the tutorials for CCv5 which are 4 in number, but they are all dealing with a single model. I want to use SQL LEFT JOINS to assemble all the information. There are 3300 rows in my biggest table with all of my members. The other tables are less than 50 rows in number & contain status, field of work, industry & committee membership. They are all recorded as foreign keys in the member table. They other tables provide human description to the codes in the member tables.

I had the list function working in CCv4, so there is something about making the JOINS work in CCv5. In CCv4 there was a JOIN rule. In CCv5 it appears similar to a high degree, but the blank page output has me wondering what it is about multiple models that produces a blank page output on Front View, View Connection.
R
RLaurel
BTW:
The Admin View, View Connection of the multiple model CCv5 Connection also produces a completely white page.

The Admin View, View Connection of the single model CCv5 Connection at produces the column titles.
R
RLaurel
OK, I have a part of a database listing working. As long as a single table is used, I get all the output of that table I need.

Adding the second model is when it breaks. I will ultimately need to add 4 additional models to make the LEFT JOINS in the 4 other tables.

I have looked at the CCv5 tutorials in the FAQ's but that only addresses a single table with no JOINS.

I can make it work in CCv4, so I can't be far off. I am trying to follow the notes I read below the input boxes for style & syntax, but I am getting nothing when I attempt anything more than reading a single table.

Ideas? Instructions? Examples?