Buy Now
Sign in

Error code 'Fatal error' using Chronoforms on Joomla 2.5.1

Davyconaert , February 28 2012
D
Davyconaert

Hello,

I've installed Chronoforms V4 RC3.2 J1.6 using Joomla 2.5.1.

I can open the component, but when I click on a menu item's 'forms manager', 'form wizard' or 'easy form wizard' I get this error code: Fatal error: Class 'ChronoFormsAdmin' not found in /customers/9/4/4/dcdigitals.be/httpd.www/JM25/administrator/components/com_chronoforms/admin.chronoforms.php on line 88.

Can someone please help me?
(Sorry if there is bad Englisch).

Regards,

Davy.

GreyHead

Hi Davy,

This is a new installation? I've just installed CFv4 RC3.2 and don't get this error. The 'missing' class is defined later in the same file so I have to guess that something was corrupted in the installation. Pleas try installing again over the existing installation and see if that fixes the problem.

Bob

ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much

D
Davyconaert

Hello,

just made a fresh install joomla 2.5.0. This is also giving error with Chronoforms. (Fatal error: Class 'ChronoFormsAdmin' not found in /customers/9/4/4/dcdigitals.be/httpd.www/Joom25/administrator/components/com_chronoforms/admin.chronoforms.php on line 26 )

I suppose the problem is only with me. But does anyone knows how I can fix this?

D
Davyconaert

Hi Bob,

I think our replies crossed. I have installed it over the existing installation. The error code stays, but line '88' is know '26'.

Davy.

D
Davyconaert

Hi Bob,

I think I found the problem. After I changed the database type from 'MySqli' yo 'Mysql' Chronoforms worked completly.

Davy.

GreyHead

Hi Davy,

OK - thanks for letting us know; I haven't seen that problem before.

Bob

ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much

D
Davyconaert

Hello again Bob.

Very strange, but today when I logged in at my site, I got the error message back. Altough I could create a form yesterday. I also published the form.

What I have done so far:

I installed joomla1.7.5 online, then Chronoforms. The same error appeared. Then I installed a local joomla 1.7.5, followd by Chronoforms. Here no error. Then I coppied the file 'admin.chronoforms.php' from local folder and put it online. Problem solved.

After that. I tried the same with local joomla 2.5.1 (local, everything works). Copy 'admin.chronoforms.php' to my online site. Here the error appaers again.

Davy.

GreyHead

Hi Davy,

It sounds like something to do with the on-line server. I suggest that you check the server logs to see if there is any more information and possibly check with your web host too.

Bob

ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much

D
Davyconaert

Hi Bob,

I chatted with the webhosting. They can not help me. They think the problem is with the component.

Is it possible to get earlier versions of chronoforms like 'ChronoForms v4 RC3.0'. If I could get this, than I can check on a JM 1.7.5 if I have the problem also.

Davy.

GreyHead

Hi Davy,

You can ask Max for old versions using the Contact Us link above. But I'm pretty certain that it won't help you. Sorry to put you between a rock and a hard place but my money is on the server being the problem here.

Bob

ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much

D
Davyconaert

Hi Bob,

I think you are right about the server, but I wont give up ;).

Always worked with JM1.5 and chronoforms. I want it to run.

I am gonna ask Max for Old versions and see where I go from that.

Thanks for your replies!

Davy.

D
Davyconaert

Hi Bob,

it was a server problem. I uploaded & new J2.5.1 install at an other hosting company. Everything runs fine from the first time.

Problem solved. The hosting where the problme was solved the problem also. What they did, I don(t now, but now it runs fine.

regards,

Davy.

GreyHead

Hi Davy,

Great, thanks for letting us know.

Bob

ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much

O
Oleksandr

I have also faced the same problem using Joomla 2.5.6 After research I found that the problem is coused by php settings on server. After I've enabled suhosin.executor.disable_emodifier in php settings of server everything works well.