Buy Now
Sign in

Chrono conflict with Sigplus gallery

scagnoz , December 14 2011, 15:32
S
scagnoz 7
December 14 2011, 15:32 #259649
When I added the form to my webpage the Sigplus gallery disappeared...
No result in adding "SC jQuery" to solve JQuery $ conflict...

This is my code:

{gallery}radicondoli/chianti{/gallery}
<p></p>
<h3>Fill the form to inquire about availability!</h3>
<br />
<br />
<p>
{chronoforms}Form-radi{/chronoforms}
</p>


This is the link to the page: http://www.2beinsiena.com/tours/chianti-tour

I tried to remove the form and the gallery comes out again...
Anyone can help?? I'can't figure out how to get back my gallery!
Thank in advance!!

Michele
GreyHead 64
December 14 2011, 15:39 #259651
Hi Michele,

Please check the DataPicker entries - there's a JavaScript error on the page that looks like a configuration error is missing something.
missing ) after argument list
[Break On This Error] new DatePicker('.input_datetim...picker_dashboard'} input_datetime_6);

new DatePicker('.input_datetime_5', {inputOutputFormat: 'd/m/Y', pickerClass: 'datepicker_dashboard'} input_datetime_6);

Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
S
scagnoz 7
December 14 2011, 15:54 #259654
Hi Bob,
I strongly hoped that you was online!!
Thank you very much for your prompt reply!

I've seen th error but I don't know how to solve, I just used the wizard to set the DataPicker, no coding...
That's it:

Field Name input_datetime_5
Field ID
Field Default Value
Field Max Length 150
Field Size 16
Field Class
Field title
Label Text Check in*
S
scagnoz 7
December 14 2011, 16:00 #259656
Disabling the form makes the gallery apper again, and, furthermore, when the Chrono is on the gallery code source appears:
</p>
<div id="sigplus_f05a38a9fcae969d99cafe47622173f4" class="sigplus-gallery sigplus-center"><ul style="visibility: hidden;"><li><a href="/images/radicondoli/chianti/Chianti1.jpg" rel="boxplus-sigplus_f05a38a9fcae969d99cafe47622173f4"><img id="sigplus_f05a38a9fcae969d99cafe47622173f4_img0000" src="/cache/thumbs/8038388b60b0f90f36e94d18a8ae8852.jpg" longdesc="/cache/preview/d91a341d4a854a551cd3117f7e0e5f36.jpg" alt="" height="100" width="150"></a></li><li><a href="/images/radicondoli/chianti/Chianti2.jpg" rel="boxplus-sigplus_f05a38a9fcae969d99cafe47622173f4"><img id="sigplus_f05a38a9fcae969d99cafe47622173f4_img0001" src="/cache/thumbs/133fe98a09677e32d540c6ba98b19dda.jpg" longdesc="/cache/preview/dd89a4ab092e02bbee0c85d22b096c3d.jpg" alt="" height="100" width="150"></a></li><li><a href="/images/radicondoli/chianti/Chianti3.jpg" rel="boxplus-sigplus_f05a38a9fcae969d99cafe47622173f4"><img id="sigplus_f05a38a9fcae969d99cafe47622173f4_img0002" src="/cache/thumbs/6d5604580e024cf9d840bd124acfb8f6.jpg" longdesc="/cache/preview/8d82101f008d055ff5d635a3f46252b1.jpg" alt="" height="100" width="150"></a></li></ul></div>
<p></p>
<h3>Fill the form to inquire about availability!</h3>


There is surely come strange conflict.

I still can't guess why the date picker disappeared...
Any idea?
S
scagnoz 7
December 14 2011, 16:12 #259657
The error in the sourcecode is here in the head scripts:
    //<![CDATA[
      window.addEvent('load', function() {
                new DatePicker('.cf_date_picker', {pickerClass: 'datepicker_dashboard', inputOutputFormat: 'Y-m-d H:i:s', allowEmpty: true});
                new DatePicker('.cf_datetime_picker', {pickerClass: 'datepicker_dashboard', inputOutputFormat: 'Y-m-d H:i:s', timePicker: true, allowEmpty: true, format: 'd-m-Y H:i:s'});
                new DatePicker('.cf_time_picker', {pickerClass: 'datepicker_dashboard', inputOutputFormat: 'Y-m-d H:i:s', timePickerOnly: true, allowEmpty: true, format: 'd-m-Y H:i:s'});
                new DatePicker('.input_datetime_5', {inputOutputFormat: 'd/m/Y', pickerClass: 'datepicker_dashboard'} input_datetime_6);
              });
    //]]>


But how can I correct it, since is a code generated automatically by Chronoforms?
S
scagnoz 7
December 14 2011, 16:30 #259659
SOLVED!
Was an error in the declaration of DateTime Picker selector under General tab of the form!

Was
input_datetime_5::{inputOutputFormat: 'd/m/Y'} input_datetime_6::{inputOutputFormat: 'd/m/Y'}


now is
input_datetime_5::{inputOutputFormat: 'd/m/Y'}|#|input_datetime_6::{inputOutputFormat: 'd/m/Y'}


Thank you very much Bob, now the gallery works as well!
All the best!

Michele
GreyHead 64
December 15 2011, 16:41 #259772
Hi Michele,

Well done!! I'm gladf you got it working OK.

Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much