Buy Now
Sign in

emails not sent

skytopdesigns , November 02 2007, 08:49
S
skytopdesigns 51
November 02 2007, 08:49 #3314
i read through the other post,and checkd the same things,

i am not getting the emails

i have the newest version and joomla 1.0.12

i have emails set you "yes" and form methid set to "post"

i put on the debug and it said "email not sent"

what do i check

thanks

_POST: Array ( [Name] => lisa [Email] => [email]zoom4267@aol.com[/email] [select] => Town [Issue] => fdfdsaf [Submit] => Submit )
Case 1: Use table layout
E-mail: 'Yes' custom
Email not sent<br><br>Post edited by: skytopdesigns, at: 2007/11/02 05:02
admin 28
November 02 2007, 16:28 #3321
Please post the whole debug output or a screenshot and your form html and your general tab screenshot and assure your site is sending emails and a special fields tab screenshot and assure you dont have anything in the action URL field

Cheers

Max
Max
If your main question got answered then please mark the answer using the button!
Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
V
vipmerv 16
November 02 2007, 17:14 #3322
I guess I know your problem man.... Try to check ur global configuration at your Joomla Administration. Then check your mailer at MAIL tab... Some server successfully running with PHP mail function but some require SMTP mailer in order to make the Joomla email sent successfully.

Hope this would help... :cheer:

Regards
Merv<br><br>Post edited by: vipmerv, at: 2007/11/02 13:15
S
skytopdesigns 51
November 02 2007, 18:17 #3324
i checked the global settings, it has to be on sendmail to work.

the full debug is

[quote
  • _POST: Array ( [Name] => lisa [Email] => [email]zoom4267@aol.com[/email] [select] => killingworth [Issue] => test 711 [Submit] => Submit )
    Case 1: Use table layout
    E-mail: 'Yes' custom
    Email not sent
    E-mail message
    From:

  • To: [email]skytopdesigns@aol.com[/email],
    Subject:

    Name lisa
    Email [email]zoom4267@aol.com[/email]
    select killingworth
    Issue test 711
    Submit Submit
    reset[/quote]the form code:
    <table width="727" height="67" border="0" cellpadding="0" cellspacing="0">
    <tr>
    <td><table width="300" border="0" align="center" cellpadding="0" cellspacing="0">
    <tr>
    <td><div align="center">
    <p>Submit a Town Issue you feel is important and should be addressed. </p>
    <p>Please include your contact information and we will get back to you at our earliest convienence </p>
    </div>
    </td>
    </tr>
    </table>
    <table width="353" border="0" align="center" cellpadding="0" cellspacing="0">
    <tr>
    <td width="80" height="30">Name</td>
    <td width="273"><input name="Name" type="text" id="Name"></td>
    </tr>
    <tr>
    <td height="30">Email</td>
    <td><input name="Email" type="text" id="Email"></td>
    </tr>
    <tr>
    <td height="30">Town</td>
    <td><select name="select" size="1">
    <option value="select town">-select town-</option>
    <option value="killingworth" selected>Killingworth</option>
    </select>
    </td>
    </tr>
    </table>
    <table width="354" border="0" align="center" cellpadding="0" cellspacing="0">
    <tr>
    <td width="96">Issue</td>
    <td width="258"><textarea name="Issue" cols="40" rows="4" id="Issue"></textarea></td>
    </tr>
    <tr>
    <td> </td>
    <td>{imageverification}</td>
    </tr>
    </table>
    <table width="300" border="0" align="center" cellpadding="0" cellspacing="0">
    <tr>
    <td><div align="center">
    <input type="submit" name="Submit" value="Submit">
    </div></td>
    <td><div align="center">
    <input name="reset" type="reset" id="reset" value="Reset">
    </div></td>
    </tr>
    </table>
    </td>
    </tr>
    </table>
    and i have attached the general and special tab

    thanks for the quick response guys
    Post edited by: skytopdesigns, at: 2007/11/02 14:24
    Post edited by: skytopdesigns, at: 2007/11/02 14:25
    Edited to add quote & code tags

    Post edited by: GreyHead, at: 2007/11/02 16:13<br><br>Post edited by: GreyHead, at: 2007/11/02 16:31
    S
    skytopdesigns 51
    November 02 2007, 18:18 #3325
    seem to be having problems uploading files<br><br>Post edited by: skytopdesigns, at: 2007/11/02 14:25
    S
    skytopdesigns 51
    November 02 2007, 18:25 #3326
    trying again
    S
    skytopdesigns 51
    November 02 2007, 18:26 #3327
    here is the general

    GreyHead 64
    November 02 2007, 20:38 #3331
    Hi Skytopdesigns,

    There aren't any file fields in this form so I'm guessing that the problem is still that you aren't receiving the emails?

    Check the 'From Email field' on the 'Special Fields' tab, it's hard to see from the image but I think you have 'emal' in there instead of 'email'. Anyhow the debug shows that there is a problem of some kind with the from email field as it shouldn't show as 'From: []'

    Bob
    ChronoForms technical support
    If you'd like to buy me a coffee or two, thank you very much
    S
    skytopdesigns 51
    November 02 2007, 21:45 #3347
    what doyou mean there arent file fields in the form?

    i do have "email" in the field.

    you can check the live form at

    http://www.mytownsbusiness.com/index.php?option=com_chronocontact&Itemid=62

    thanks forthe reply
    S
    skytopdesigns 51
    November 02 2007, 22:08 #3350
    cleared all of the spcial fields and it worked.

    thanks to ainother post

    what are the special fields for?

    thanks alot!!!
    GreyHead 64
    November 02 2007, 22:38 #3355
    Hi skytopdesigns,

    The 'special fields' take field names from your form and use the values of the fields.

    Bob
    ChronoForms technical support
    If you'd like to buy me a coffee or two, thank you very much
    S
    skytopdesigns 51
    November 02 2007, 22:51 #3357
    why does it work with the special fields empty?
    GreyHead 64
    November 02 2007, 23:59 #3358
    Hi skytopdesigns,

    Probably because you had an error in the special fields.

    Bob
    ChronoForms technical support
    If you'd like to buy me a coffee or two, thank you very much
    S
    skytopdesigns 51
    November 03 2007, 00:01 #3359
    okay. it works so illleave them blank

    thaks alot