Buy Now
Sign in

Help Uploading files in Crono Forms for Joomla 1.5

Yaholo , November 02 2007, 01:26
Y
Yaholo 3
November 02 2007, 01:26 #3295
What am I doing wrong? I cannot get files to upload at all. I know to look under the "uploads" directory in "com_chronocontact" but nothing is there. I also have file permissions set correct. Below is my code and settings.

<input name='Photo_of_Director' type='file' class='inputtext'>
<br><br>Post edited by: Yaholo, at: 2007/11/01 21:27
GreyHead 64
November 02 2007, 01:52 #3304
Hi Yaholo,

That all looks OK to me - can you post a link to the form please?

Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
Y
GreyHead 64
November 02 2007, 01:56 #3306
Hi Yaholo,

Hmmm, that looks good too . . . scratches head . . .

Perhaps Max has a bright idea?

Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
admin 27
November 02 2007, 16:05 #3316
Hi,

There is a bug in the J1.5 version, line 530 at chronocontact.php:

Please make it :

$upload_path = JPATH_BASE.'/components/com_chronocontact/upload/';


This will do it

Cheers

Max
Max
If your main question got answered then please mark the answer using the button!
Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
G
gg4j 114
November 02 2007, 21:32 #3343
Hi Max set the line, instead of:
$upload_path = $mosConfig_absolute_path.'/components/com_chronocontact/upload/';


Files are uploaded fine, in the folder, but there's no track of the filename in the record of the sql table...
I mean the field matched to field type="file" is empty...

Why? Scratching head as well...
Y
Yaholo 3
November 03 2007, 00:43 #3361
The fix worked! Thank you very much.
admin 27
November 03 2007, 17:23 #3374
Thanks Yaholo, gg4j:

In order to have file name stored you will need to edit the autogenerated code alittle, find the $_POST['file_field_name'] and replace it with $_FILES['file_field_name']['name']

Cheers

Max
Max
If your main question got answered then please mark the answer using the button!
Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!