Buy Now
Sign in

How do I check for required fields?

shank , October 11 2007, 03:22
S
shank 14
October 11 2007, 03:22 #2735
I have 3 file attachments, and then various radial and fields that I need required to have data in. How do I check for this?
GreyHead 64
October 11 2007, 16:07 #2742
Hi shank,

Use the latest version of ChronoForms (as there have been some bug-fixes in form validation).

Select the Validation tab for your form, Enable Validation and put a comma separated list of field names in the 'required' field.

In your html code field make sure that you *do not* have any class attributes for fields that you want validated.

Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
S
shank 14
October 11 2007, 22:08 #2744
Do you know to check the version currently running on my server? it seems the latest version on the site is in beta

Also what do you mean by class?

thanks again
Attachments
my valuation form.png
my valuation form.png
(69.83 KiB)
39 Downloads/Views
GreyHead 64
October 11 2007, 22:18 #2745
Hi shank,

If your site is Joomla 1.0.x then you should use ChronoForms 2.3.4 from the Download area here.

The 'class' attributes are any "class='somename'" entries in your form field html.

Bob
Attachments
frederiks form.png
frederiks form.png
(61.33 KiB)
78 Downloads/Views
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
S
shank 14
October 11 2007, 22:23 #2746
hello. I uninstalled my existing chronos 2.3.2 and installed the new version. i dont see any class attributes listed in the field i am trying to validate.

when i click submit, i can see errors on page in my ie status window, but then it continues to send the information and i receive an email
GreyHead 64
October 11 2007, 23:17 #2748
Hi shank,

Is that now doing what you want?

Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
S
shank 14
October 11 2007, 23:33 #2750
Hello.

No. When I submit an empty form with field validation enabled for one field, in the IE status window it shows errors on page real quick, but continues to submit the page and takes the user to the thank you page. I guess what is the form validation supposed to do? shouldn't it not allow you to submit the form if the field doesn't have any information in it? I tried require checkbox also for one, and that also failed...

failed meaning, it submitted the inforamtion anyway
admin 27
October 11 2007, 23:47 #2754
Hi Shank,

Doesi t work fine under FF ? Can you post this Page URL please if its online ?

Cheers

Max
Max
If your main question got answered then please mark the answer using the button!
Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
S
shank 14
October 11 2007, 23:59 #2755
S
shank 14
October 12 2007, 00:08 #2757
firefix? I meant firefox sorry.
admin 27
October 12 2007, 01:58 #2763
Shank, Iam sorry I can't open the page right now coz I have some problems browsing too many websites, I will look once fixed

Cheers

Max
Max
If your main question got answered then please mark the answer using the button!
Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!