Buy Now
Sign in

[Resolved] Image Verification not working

sswithjs1 , October 10 2007, 13:27
S
sswithjs1 4
October 10 2007, 13:27 #2703
Joomla! Version: Joomla! 1.0.12 Stable
MySQL Version: 4.1.14-standard
PHP Version: 4.3.10-19
ChronoForms Version: 2.3.4

Whatever I enter 'Sorry, You have entered a wrong verification code' even correct code.

I've added $chrono_verification, md5($chrono_verfication) and $_SESSION['chrono_verfication'] at the end of showErrorMessage to debug and found the last one, $_SESSION['chrono_verfication'], is null value.

There is session file created in defined directory in php.ini.

Session Support enabled
Registered save handlers files user
Directive Local Value
session.auto_start Off
session.bug_compat_42 On
session.bug_compat_warn On
session.cache_expire 180
session.cache_limiter nocache
session.cookie_domain no value
session.cookie_lifetime 0
session.cookie_path /
session.cookie_secure Off
session.entropy_file no value
session.entropy_length 0
session.gc_divisor 100
session.gc_maxlifetime 1440
session.gc_probability 0
session.name PHPSESSID
session.referer_check no value
session.save_handler files
session.save_path /home/2/e/9/8575/8575/tmp
session.serialize_handler php
session.use_cookies On
session.use_only_cookies Off
session.use_trans_sid Off

There are only two (session) values in configuration.php
$mosConfig_session_life_admin = '1800';
$mosConfig_session_type = '0';

What could be the reason $_SESSION['chrono_verfication'] doesn't have any value?

Thanks in advance,

Post edited by: sswithjs1, at: 2007/10/10 09:32<br><br>Post edited by: sswithjs1, at: 2007/10/10 10:52
S
sswithjs1 4
October 10 2007, 13:44 #2704
verified there is a file in session.save_path with
chrono_verfication|s:32:"value of <md5($chrono_verfication)>";vercode|i:55593; and matches with md5($chrono_verfication).

I believe the way to get $_SESSION['chrono_verfication'] is something wrong and failed if clause.
GreyHead 64
October 10 2007, 13:47 #2705
Hi sswithjs1,

Not sure where the error is (in ChronoForms or your check code) but I think that should be $_SESSION['chrono_verification'].

Will check the code later.

Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
S
sswithjs1 4
October 10 2007, 14:06 #2706
Thanks for quick response.

Should mention where I found the code:
chronocontact.php and search for the 'Sorry'

Since other people are working fine, looks like my session specific config issue but really want to make this work

Thanks again,
S
sswithjs1 4
October 10 2007, 14:53 #2708
Found the issue:

I'm using JSMF and there is a configuration to prevent this wonderful feature:

Source:
http://extensions.joomla.org/component/option,com_mtree/task,viewlink/link_id,1802/Itemid,35/
Known Issue: Sites with JSMF component from Joomlahacks must go to SMF Admin ==> Server Settings ==> Feature Configuration and disable: Use database driven sessions.

Thanks and hope I'll be living in spam-free world.