Buy Now
Sign in

ChronoForms v3 & v4 and Joomla! 1.6

GreyHead , February 25 2011
GreyHead

Hi there,

Updated post

ChronoForms v3 requires Joomla! 1.5

From Joomla! 1.5.18 there is an optional MooTools Upgrade Plugin that will enable the MooTools 1.2 library on your site. If you need the plug-in you should update your Joomla! installation to the latsest release, currently 1.5.23, as some earlier releases did not implement the plug-in correctly.

ChronoForms v3 requires the MooTools 1.12 library that is installed in Joomla! 1.5 by default. If the MooTools 1.2 plug-in is enabled then the ChronoForms Wizard, and other back-end code will not run nor will validation, tooltips, datepickers and other JavaScript dependent parts of ChronoForms forms.

ChronoForms v4 form Joomla! 1.5 requires MooTools 1.2 and so will only run in Joomla! 1.5.18 or later with the MooTools upgrade plug-in enabled. If you run ChronoForm v4 you should update your Joomla! installation to the latsest release, currently 1.5.25, as some earlier releases did not implement the plug-in correctly.

ChronoForms v4 is also released for Joomla! 1.6/1.7/2.5 These releases require the MooTools 1.3/1.4 library installed as standard with Joomla!


Note: If you need to run ChronoForms v3 and need MooTools 1.2 in the front-end of your site then there is a hack for the MooTools Upgrade plug-in posted in the forums here that will enable the 1.2 library in the front-end only. However the ChronoForms validation code and some other features will not work with this version.

There's a fuller "How-to Document" here that includes fixed files that will let the front-end of ChronoForms work with MooTools 1.2.


Bob

ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much