Buy Now
Sign in

Captcha never works first time around

lateupdate , January 15 2009
l
lateupdate

Hi,

This component is really cool and I like that you intend to eventually extend it to become included into other components. Great work guys!

I'm having a problem and I can't figure out how to begin the search for a solution. Every time I visit the site, no matter how careful I am to get it right, the captcha code never works the first time around! As soon as it is refreshed on the page, then it works fine.

This happens whether I use the small captcha or the bigger one. (I like the bigger one btw!)

Any idea why this would be happening? A work-around or band-aid if there's no solution? Thanks!

(using J!1.5.9)

admin

Hi lateupdate, try to do this with our comments here at the site, from the home page try to comment at any article there and let me know!

Regards
Max

Max
If your main question got answered then please mark the answer using the button!

l
lateupdate

Seems to work on the homepage of this site, but still not on my own site -- maybe this has something to do with the cache? I'm not sure why but I'll also get core Joomla errors that say it could not delete certain folders, when I save a new article.

admin

it may be the cache or the permissions yes, try to set the "sessions handler" to database in the Joomla global config!

Regards
Max

Max
If your main question got answered then please mark the answer using the button!

J
Jemster

Hi,

I am a fan of ChronoComments and use it on my website: <!-- w --><a class="postlink" href="http://www.anglofeb.com">www.anglofeb.com</a><!-- w -->

Unfortuantely I have had issues getting Captcha to work since installating the application a couple of months back and in the end gave up and disabled it. I am now at my wits end with all the spam I am receiving and desperately want to get Captcha working. Could someone please look into this for me? Here is an example of where I use ChronoComments: http://www.anglofeb.com/editorial/features/7-features/838-fenerbahce-blog-has-arrived.html

Thank you in advanced :)

admin

Hi Jemsetr,

when I try to load the captcha file here:
http://www.anglofeb.com/components/com_chronocomments/chrono_verification.php?imtype=1&anticache=83027

you can see the most common 2 problems, try to check them both and see if any fixes it ?

regards
Max

Max
If your main question got answered then please mark the answer using the button!

J
Jemster

Thank you for your swift reply

Most Perms settings are 755 or below apart from 2 and lowering them affects the load secondary pages :?:

Anything else you can suggest?

admin

Whats the permissions of this file :
http://www.anglofeb.com/components/com_chronocomments/chrono_verification.php
??

if you made a search in the forums here, you will find different solutions posted by users, this file is used in 2 extensions!

Let me know!

Regards,
Max

Max
If your main question got answered then please mark the answer using the button!

J
Jemster

Hi Max,

Thanks to your help, I sourced the problem through the error logs. The permissions set were too low (666) and I tweaked it to 750 and it now works like a charm. Thank you for your help :)

Jem

admin

Hi Jem,

great, that was for the file, correct ?

thanks for letting me know!

Regards
Max

Max
If your main question got answered then please mark the answer using the button!

J
Jemster

Hi Max,

I changed of the permission of the file titled "chrono_verification.php" from 666 to 750 at the webserver backend

Hope that helps.

admin

Thanks for posting the exact fix!

Max

Max
If your main question got answered then please mark the answer using the button!

l
liza09

Jemster:

Hi Max,

I changed of the permission of the file titled "chrono_verification.php" from 666 to 750 at the webserver backend

Hope that helps.



This helped me too. Thank you!

Regards,
Liza
Pret travaux

B
Bonzo

Does anyone notice the Captcha codes never work? They always say incorrect.
It’s been like that all year and when it finally does work you get the same comments posted 9 times. No wonder my friends just delete everyone that requires them.