Buy Now
Sign in

uft-8 Russian language troubles

fkker , November 09 2008
F
fkker
Hello The Creator!
I like CronoComments, but I have got Russian text displayed incorrectly right after sending (see pics in attach Snap1)
If i reload - last comment becomes OK.... but if i post new one - the same situation.

PS - DB is ok

<html lang="en-gb" xmlns="http://www.w3.org/1999/xhtml" xml:lang="en-gb" dir="ltr">
...
<meta content="text/html; charset=utf-8" http-equiv="content-type"/>


help me pls

Thanx!
Attachments
Snap2.jpg
Snap2.jpg
(25.48 KiB)
7584 Downloads/Views
Snap1.jpg
Snap1.jpg
(30.14 KiB)
7583 Downloads/Views
admin
Hi fkker,

I'm sure this is some issue with your site or template somewhere, for example, do this test here at our site and it will work fine all time, other russian users already using it so no problem with the plugin itself!

Regards
Max
Max
If your main question got answered then please mark the answer using the button!​
​Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
F
frezeriv
Hello! You have found out in what a problem?
Please!.. I have your component as a unique variant for my site
admin
Hi frezeriv, I'm not sure why this happens exactly but its something to do with your site, did you edit any ChronoComments files ?

Max
Max
If your main question got answered then please mark the answer using the button!​
​Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
F
frezeriv
Yesterday I have found the reason, all problem consisted in locale at a hosting. Excuse me for troubling.
admin
Hi frezeriv,

No problems, If you can give more details about the solution then this will help everyone get the same issue in the future too!

Regards
Max
Max
If your main question got answered then please mark the answer using the button!​
​Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
F
frezeriv
I have transferred a site from one hosting on another. The problem was in локали a server on which there was a site. On the previous hosting locale was cp1251, site coding is utf8, on a present hosting locale utf8. I am not assured, but I think the reason in it.
admin
Thanks!

Max
Max
If your main question got answered then please mark the answer using the button!​
​Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
G
Grunge
Gentlemen, I also have a problem: in a posted comment instead of russian text it shows ??? only...

I try to modify it via admin interface of Chronocomments, but it does not work...
What could be the issue? Appreciate any help
G
Grunge
Let me answer my question myself - just in case other will encounter the same.

My problem was caused by wrong language settings in the database. Somehow it was set to 'latin_swedish_ci', don't know why... whatever

Changing COLLATE setting for the 'text' field in the table 'jos_chrono_comments' to 'utf8_general_ci' in phpMyAdmin solved the problem.