Buy Now
Sign in

The form stopped working and debugger doesn't show anything

Alistair , January 22 2020, 07:00
A
Alistair 95
January 22 2020, 07:00 #390838
The form (after working fine for ages) is not being sent anymore, there is a small circle in the middle of the page then that's it, no thank you message, no form being sent. I have enabled the debugger but it doesn't seem to work, so I wondered if anything changed lately to make it stop working so abrupdly. Thanks.
A
Alistair 95
January 22 2020, 15:45 #390854
Ok, I managed to get the debugger working sorry:
Array
(
[chronoform] => enquiry
[event] => submit
[name] => prova
[company_name] =>
[country] =>
[email] => xxxxxx@gmail.com
[telephone] =>
[your_request] => prova
[file2] => Array
(
[0] =>
)

[deadline_for_quotes] =>
[deadline_for_goods] =>
[button21] =>
[how_did_you_find_us] =>
[Itemid] => 122
[option] => com_chronoforms6
[view] => form
)
Array
(
[submit_validate_fields] => Array
(
[log] => Automatic validation enabled.
[var] => 1
)

[validate_fields6] => Array
(
[log] => Automatic validation enabled.
[var] => 1
)

[upload2] => Array
(
[path] => /web/htdocs/www.xxxxxx.com/home/components/com_chronoforms6/chronoforms/uploads/
[file2.[n]] => Array
(
[extensions] => Array
(
[0] => jpg
[1] => png
[2] => gif
[3] => pdf
[4] => doc
[5] => docx
[6] => txt
[7] => zip
[8] => jpeg
[9] => rtf
)

)

[file2.0] => Array
(
[saved] => 0
)

[var] => Array
(
[file2] => Array
(
[0] => Array
(
)

)

)

)

[load_validate_fields] => Array
(
[log] => Automatic validation enabled.
[var] => 1
)

)
admin 28
January 24 2020, 04:00 #390887
If the small circle does not disappear then you may have a javascript error on the page of the form, but how do you get the debugger data then ?
Max
If your main question got answered then please mark the answer using the button!
Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
A
Alistair 95
January 24 2020, 07:40 #390890
The small circle disappears and you land back to the form page, without the form being sent. While there should be no circle, the form should be sent with the thank you message showing.
I have another form on the very same website and everything works fine.
healyhatman 9
January 24 2020, 12:40 #390901
Does the file get uploaded?
Web developer at SkySpider.com.au - I DO NOT work for ChronoEngine!
Donations: paypal.me/healyhatman
Professional Work: kamron@skyspider.com.au
Custom CF / CC Plugins and Extensions: skyspider.com.au/store
A
Alistair 95
January 24 2020, 12:54 #390904
Hi, I hadn't even tried with the file attached as I saw the email wouldn't arrive, I have now tried attaching a file and not only does the attachment upload but the email is sent correctly (including the thank you message). So the issue happens only when users do not upload any files (field not mandatory).
healyhatman 9
January 24 2020, 13:04 #390905
The "fail" event for the file upload is called when there's no file to upload when you specify a file field to be uploaded. Put it inside an event switch with data source {data.empty:file2} in the "false" branch.
Web developer at SkySpider.com.au - I DO NOT work for ChronoEngine!
Donations: paypal.me/healyhatman
Professional Work: kamron@skyspider.com.au
Custom CF / CC Plugins and Extensions: skyspider.com.au/store
A
Alistair 95
January 25 2020, 07:34 #390910
Put it inside an event switch with data source {data.empty:file2} in the "false" branch.
I don't understand what that means. The form has worked with these settings for a long time, so not sure what changed. Unfortunately I don't understand those instructions.
Cattura.JPG
Attachments
Cattura.JPG
Cattura.JPG
(57.03 KiB)
134 Downloads/Views
admin 28
January 26 2020, 09:39 #390920
Hi Alistair,
do you have the same issue with the demo contact form ? are you able to attach a backup of your form or send me a message using the contact page and attach the form file.
What is your Joomla version ?
Max
If your main question got answered then please mark the answer using the button!
Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
A
Alistair 95
January 27 2020, 07:15 #390929
Hello, I'm attaching the back-up of the form.
I'm on Joomla! 3.9.14
A
Alistair 95
January 29 2020, 06:57 #390954
Edit: now on version 3.9.15
A
Alistair 95
February 01 2020, 10:32 #390995
Put it inside an event switch with data source {data.empty:file2} in the "false" branch.
Can this be translated/simplified by anyone?
healyhatman 9
February 01 2020, 10:47 #390996
Web developer at SkySpider.com.au - I DO NOT work for ChronoEngine!
Donations: paypal.me/healyhatman
Professional Work: kamron@skyspider.com.au
Custom CF / CC Plugins and Extensions: skyspider.com.au/store
A
Alistair 95
February 03 2020, 07:17 #391015
So, do I put the Event switcher before the Upload files?
healyhatman 9
February 03 2020, 07:18 #391016
You put the upload inside the event switcher just like in the screenshot
Web developer at SkySpider.com.au - I DO NOT work for ChronoEngine!
Donations: paypal.me/healyhatman
Professional Work: kamron@skyspider.com.au
Custom CF / CC Plugins and Extensions: skyspider.com.au/store
A
Alistair 95
February 03 2020, 08:16 #391019
THANK YOU!