Buy Now
Sign in

Getting Empty message body

directivemsp , November 08 2019, 15:14
D
directivemsp 80
November 08 2019, 15:14 #389934
Hello,
we are getting Empty message body error while submitting form, the concern is that we are not having this everytime we submit the form, but when cache is on in global config we get this issue on some devices and browsers, please provide a solution to fix the issue ASAP.
we are using form module with no cache setup in settings, not article.
please see screenshot: https://drive.google.com/file/d/1QlGNYrR-KNBixRermY1PlPtY_8WBCwi4/view?usp=sharing

also same issue here  https://www.chronoengine.com/forums/posts/t107226/cf6-caching-my-forms-they-are-not-submitting   
GreyHead 64
November 10 2019, 14:54 #389945
Hi directivemsp,
The most likely explanation is that your form is not set up correctly.
If you are using one of the ChronoForms Captchas then caching the form page will prevent it from working.
If you do not have ServerSide Validation set up then you can get blank submissions.
If you are using the form in a module then you may need to set the Action URL to prevent problems with data being lost on submission.
Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
D
directivemsp 80
November 11 2019, 10:18 #389951
Hello

i have checked configuration of the form and also created new form but still getting "empty message body " sometimes.
here i am attaching form please check and provide a solution to fix this issue asap.
Attachments
dinners-test-form_11_Nov_2019_10_16_38.cf6bak
(25.78 KiB)
11 Downloads/Views
D
directivemsp 80
November 12 2019, 16:18 #389974
We need an update on this issue, with caching enabled ( a core built in function of joomla ) your software doesn't work, forms do not submit and we get an "empty message body" on submission. I have confirmed this same issue exists on multiple websites. We are using google recaptcha, not the built in one, the forms are properly validated, we are having this issues both using the CF module and CF short code. We have tried with the content plugin enabled and disabled. Same results every time page caching and joomla conservative caching is active. With caching disabled they appear to work fine. We are not disabling caching, its a core function of joomla and improves speed.
This is a major issue, please escalate.
GreyHead 64
November 12 2019, 16:43 #389976
Hi directivemsp,
Have you tried setting the Action URL? If that does not resolve this, please use the Contact menu above to ask Max, the developer and owner.
Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
D
directivemsp 80
November 14 2019, 15:50 #390003
Hello

i have tried setting the Action URL, but still issue not resolved.
can you please check this to the "Max" developer please.

it is a major issue, provide a solution to fix this issue asap.
B
beykeysr 16
November 14 2019, 22:39 #390007
I'm having a problem with blank notification emails as well. When I test using the "view' feature in the Forms Manager, then I receive the data without issue. However, when the form is included in an article, then I don't receive the data, nor does it get saved to a data table. I would like to try "setting the Action URL" but I'm not sure how to do that. Is there somewhere I can refer to that guides me how to 'set the Action URL?"