Buy Now
Sign in

2nd dropdown disappears on dynamic reload

megana , June 05 2019, 20:11
M
megana 192
June 05 2019, 20:11 #387295
Hi all, first time using dynamic dropdowns and I've been working from the demo for reference. My problem is that when I pick something from my first dropdown, instead of reloading the second dropdown, the second dropdown just disappears. I've seen a few other posts with similar issues, but haven't found a solution that worked for me yet. Can anyone help?
Dropdown 1:
- Event tab has "Change" for the triggering event, "Reload" for the triggering action, and "client_id" for affected elements
Dropdown 2:
- Name/ID is client_id, but also has field_select31 for the label
- Advanced tab has "dynamic_client" for the reload event
My 'dynamic_client' event only has a custom code action right now, with {view:field_select31} in it, not even trying to do anything else at this point. When I preview the form and add &event=dynamic_client to the end of the URL, it does display the field.
healyhatman 9
June 05 2019, 23:17 #387297
In the settings for the reload event, make sure it's set to "standalone" and that the "Auto display view" option is disabled.
Web developer at SkySpider.com.au - I DO NOT work for ChronoEngine!
Donations: paypal.me/healyhatman
Professional Work: kamron@skyspider.com.au
Custom CF / CC Plugins and Extensions: skyspider.com.au/store
M
megana 192
June 06 2019, 14:35 #387305
I found "Auto display view" and disabled it, but that's the only thing on the Settings tab. I'm not sure where to find "standalone"...help?
I checked to make sure my CF is updated too.
EDIT: I found the setting to switch the "Designer mode" to the new 6.1 mode, and now I was able to find where to set the event to "standalone", however it still didn't help. Any other ideas?
M
megana 192
June 06 2019, 15:16 #387307
Actually, if I access the form via my ChronoConnectivity connection, it still has the same behavior as before (second dropdown disappears), but if I access the form directly via the Preview button, the second dropdown doesn't seem to be reloading at all.
M
megana 192
June 06 2019, 15:40 #387308
Well, I just opened up the CC connection and it's gone all wonky on me...none of my Functions have any names, and even if I delete them and re-add them, I can't specify the names and after I save, the new names disappear too. I don't know what happened between yesterday and today (it was already up to date before I started on this project), but now I'm scared to touch anything else.
This bug: http://www.chronoengine.com/forums/posts/t107329/problem-with-new-update
I guess I'm stuck until this gets resolved.
healyhatman 9
June 06 2019, 21:50 #387315
Yeah that issue is separate and no response on it yet.
Can I see your reload event?
Web developer at SkySpider.com.au - I DO NOT work for ChronoEngine!
Donations: paypal.me/healyhatman
Professional Work: kamron@skyspider.com.au
Custom CF / CC Plugins and Extensions: skyspider.com.au/store
GreyHead 64
June 07 2019, 09:38 #387331
Hi,
I see that Max has posted that this is a known bug to be fixed in the next release.
Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
M
megana 192
June 07 2019, 16:14 #387348
Got the update, yay.
Back on topic, I was going to review the demo form again to see if I'd lost anything due to the bug, but now I can't find the demos.
So here are some screenshots of my setup: https://imgur.com/a/wbHeYtN
healyhatman 9
June 07 2019, 22:53 #387354
Got a link to the form I can see?
Web developer at SkySpider.com.au - I DO NOT work for ChronoEngine!
Donations: paypal.me/healyhatman
Professional Work: kamron@skyspider.com.au
Custom CF / CC Plugins and Extensions: skyspider.com.au/store
M
megana 192
June 10 2019, 13:53 #387372
I'm having some other CFv6 issues with other forms, so I'm probably just going to go back to using CFv5 for everything for now. As much as I'd like to only be working in CFv6 going forward, it's taking up way too much time between the bugs, changing functionality, outdated documentation, moving/disappearing demos, etc. Even with how promising CFv6 looks and with many years of good experiences with CFv5 and CFv4 before that, I'm about at the end of my rope with CFv6.
Thanks anyway, healyhatman, for your help.
healyhatman 9
June 10 2019, 22:39 #387382
 1
By the way demos are now under "New Form"
Web developer at SkySpider.com.au - I DO NOT work for ChronoEngine!
Donations: paypal.me/healyhatman
Professional Work: kamron@skyspider.com.au
Custom CF / CC Plugins and Extensions: skyspider.com.au/store
M
megana 192
June 11 2019, 15:12 #387403
 Answer
Thanks! I decided to give it one more shot...
I think previously the demo forms were still using the "classic" mode, so now that it's using the new 6.1 mode the same as my form, I was able to more closely match all of the options that were toggled.
Weirdly, my form still doesn't work by itself but it does work when accessed via my CC connection, which is what I really wanted but what I thought would be harder or impossible to do. I had to add my dynamic_client event in CC instead of CF and also add the dropdown field under the CC views, but now it's working beautifully.
healyhatman 9
June 11 2019, 21:03 #387405
That does sound weird
Web developer at SkySpider.com.au - I DO NOT work for ChronoEngine!
Donations: paypal.me/healyhatman
Professional Work: kamron@skyspider.com.au
Custom CF / CC Plugins and Extensions: skyspider.com.au/store