Buy Now
Sign in

Having issue with saving form

directivemsp , May 24 2019, 16:10
D
directivemsp 82
May 24 2019, 16:10 #387036
Hello

I am having issue with saving form and got this error.
attached the form
Error: Row size too large. The maximum row size for the used table type, not counting BLOBs, is 65535. This includes storage overhead, check the manual. You have to change some columns to TEXT or BLOBs .

Joomla version - 3.9.6
PHP version - 7.2

please check this and resolve the issue
Thanks
admin 28
May 27 2019, 15:52 #387066
For now you may try to open the #_chronoengine_forms6 table in the database and set the "sections" field to "longtext", that should work until the new update it out!
Best regards
Max
If your main question got answered then please mark the answer using the button!
Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
D
directivemsp 82
May 28 2019, 09:32 #387081
Hello

I have made the changes on this table #_chronoengine_forms6 in the database and set the "sections" field to "longtext"
but it's not working, same error is generating.

Please resolve this asap.
healyhatman 8
May 28 2019, 12:45 #387089
Do the same thing for functions
Web developer at SkySpider.com.au - I DO NOT work for ChronoEngine!
Donations: paypal.me/healyhatman
Professional Work: kamron@skyspider.com.au
Custom CF / CC Plugins and Extensions: skyspider.com.au/store
D
directivemsp 82
May 28 2019, 13:11 #387090
already did.
D
directivemsp 82
May 29 2019, 13:03 #387126
Hello

Please provide resolution for the issue, also let me know when the next update will be available.
admin 28
May 29 2019, 16:16 #387138
I can not reproduce this issue here, are you usre that you have updated the field type of your forms6 table ?
Best regards
Max
If your main question got answered then please mark the answer using the button!
Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
D
directivemsp 82
May 30 2019, 15:54 #387158
I have made the changes on this table forms6 in the database and set the "sections" field to "longtext" and "functions" field also
but still getting same issue while saving the form.
form is already attached in the ticket.
D
directivemsp 82
May 31 2019, 15:29 #387181
Please try to reproduce the issue at your end using form i have given to you.
the issue is still not resolved by the given instructions
please provide resolutions asap!
admin 28
June 03 2019, 12:35 #387228
How does it work with the new update ?
Best regards
Max
If your main question got answered then please mark the answer using the button!
Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
D
directivemsp 82
June 04 2019, 15:23 #387260
updated chronoform with the latest version
but still issue not resolved.
please check asap
healyhatman 8
June 04 2019, 21:29 #387269
Is your form particularly large?
Web developer at SkySpider.com.au - I DO NOT work for ChronoEngine!
Donations: paypal.me/healyhatman
Professional Work: kamron@skyspider.com.au
Custom CF / CC Plugins and Extensions: skyspider.com.au/store
D
directivemsp 82
June 05 2019, 15:34 #387294
Yes, it's very large, already attached in ticket.
please provide resolutions asap.
D
directivemsp 82
June 12 2019, 15:21 #387430
are you able to replicate the issue on form i have sent to you
still not get any proper solutions for that
please resolve the issue asap
healyhatman 8
June 12 2019, 22:14 #387440
I'm able to replicate the issue but I'm not sure why it's happening yet, because those fields are simply not that big they're nowhere near hitting the LONGTEXT limit.
Web developer at SkySpider.com.au - I DO NOT work for ChronoEngine!
Donations: paypal.me/healyhatman
Professional Work: kamron@skyspider.com.au
Custom CF / CC Plugins and Extensions: skyspider.com.au/store
D
directivemsp 82
June 13 2019, 16:09 #387469
please resolve the issue as you are replicating it right now, i have to deploy it to live site.
D
directivemsp 82
June 18 2019, 15:15 #387639
hello
it's almost 15 days ago issue
i am still waiting for solution.
healyhatman 8
June 19 2019, 04:06 #387648
 Answer
FIGURED IT OUT
You are saving your data to the database, and you've selected "Auto Manage Data Table". But your form has HUNDREDS of fields, and MYSQL has a maximum size all of the columns together can be. Simply no getting around it - it's got nothing to do with Chronoforms.
You need to design your data table properly, with the correct data types for the fields, don't use "Auto manage data table", and only save the fields you actually need. If you really truly need all of them, make sure they're the right type. For example if it's a checkbox you want "boolean" not "varchar(60)" and you want your checkbox to be sending a 1 or 0 not "YES / NO"
Web developer at SkySpider.com.au - I DO NOT work for ChronoEngine!
Donations: paypal.me/healyhatman
Professional Work: kamron@skyspider.com.au
Custom CF / CC Plugins and Extensions: skyspider.com.au/store
healyhatman 8
June 19 2019, 04:08 #387649
Additionally, instead of having "employer1 employer2 employer3 .... employer 5" you should use a repeater area, and you should split the employer off into a separate data table or at the very list have all employer data in a single JSON column.
Web developer at SkySpider.com.au - I DO NOT work for ChronoEngine!
Donations: paypal.me/healyhatman
Professional Work: kamron@skyspider.com.au
Custom CF / CC Plugins and Extensions: skyspider.com.au/store
healyhatman 8
July 30 2019, 10:00 #388506
 1
I spent a lot of time figuring this out for you, still annoyed I didn't get a response
Web developer at SkySpider.com.au - I DO NOT work for ChronoEngine!
Donations: paypal.me/healyhatman
Professional Work: kamron@skyspider.com.au
Custom CF / CC Plugins and Extensions: skyspider.com.au/store