Buy Now
Sign in

external db connection

peppelaria , February 25 2019, 18:07
peppelaria 159
February 25 2019, 18:07 #384178
 1
Hi Max, I'm having an issue before las chronoform update.
working with external db, it tryes to call the table id instead of the table name (i.e. dbname.56). the error code is 1146, obviously the searched table don't exist.
Can you verify this strange behavior?
Thanks in advance
peppelaria 159
February 25 2019, 19:06 #384179
Another trouble I'm facing is that if I put the primary key in read data action and join rules, the join rule doesn't work, instead it takes tables primary keys, then I have to delete the join primary key in every read data action with joins
healyhatman 7
February 25 2019, 21:07 #384180
Should only put the primary key in the extra models if it's ACTUALLY a primary /foreign key. Otherwise use the manual relationship.
Web developer at SkySpider.com.au - I DO NOT work for ChronoEngine!
Donations: paypal.me/healyhatman
Professional Work: kamron@skyspider.com.au
Custom CF / CC Plugins and Extensions: skyspider.com.au/store
peppelaria 159
February 25 2019, 21:14 #384181
Thank you healyhatman. But the real problem is the external dB connection. I hope that a solution will come as soon as possible. It appended with the last chronoform update. Before it all worked fine
healyhatman 7
February 25 2019, 21:26 #384182
What about the NEW latest update?
Web developer at SkySpider.com.au - I DO NOT work for ChronoEngine!
Donations: paypal.me/healyhatman
Professional Work: kamron@skyspider.com.au
Custom CF / CC Plugins and Extensions: skyspider.com.au/store
peppelaria 159
February 25 2019, 21:26 #384183
Tomorrow I will do some other test, but I'm really sure that in the last update is passed the table id instead of the table name. I hope you can solve it soon
peppelaria 159
February 25 2019, 21:29 #384184
Please read my first post of this topic for details. I'm having a great problem with external dB connection
peppelaria 159
February 26 2019, 07:07 #384192
Hi healyhatman. Is there a way to fast hack the read data action code in order to pass the table name instead of table id?
It would be a good solution to my problem.
Thank you
healyhatman 7
February 26 2019, 07:16 #384193
In libraries/cegcore2/admin/chronoforms/extensions/functions/read_data can't help more than that sorry I'm out at the moment
Web developer at SkySpider.com.au - I DO NOT work for ChronoEngine!
Donations: paypal.me/healyhatman
Professional Work: kamron@skyspider.com.au
Custom CF / CC Plugins and Extensions: skyspider.com.au/store
peppelaria 159
February 26 2019, 07:18 #384194
Ok. I will let you know if it works.
Thank you very much
peppelaria 159
February 26 2019, 08:42 #384195
hi healyhatman, as I thought, in the y1zly_chronoengine_forms6 table I found that in the "functions" column corresponding to the form in which I use external db connection, inside the json the "db_table" param value is an ID instead of a table name.
For the moment I can manage replacing ids with table names directly in the json corresponding the interessed forms.
I know you're out at te moment, but if you coud be more precise to tell me what is the function that manage external db tables I could save some time to make some correction.
Thank you
peppelaria 159
February 26 2019, 09:10 #384196
Replacing IDs with table name make the form working. The problem occurs when I save the form, but for the moment I can manage it by changing IDs into table names.
I hope you can solve this soon.
admin 27
February 27 2019, 19:27 #384232
 Answer
Yes, bug confirmed and should be fixed in the next update!
Thank you peppelaria!
Best regards
Max
If your main question got answered then please mark the answer using the button!
Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!