Buy Now
Sign in

In BDD : name of tables is changing

glazweb , February 21 2019, 14:17
G
glazweb 18
February 21 2019, 14:17 #384053
Hello.
In Chronoforms V6, I have 4 forms linked to 4 tables in database.
For some unkown reasons, when I open one of those tables in the form manager to manage entries, the name of the table is changing.
Name is for instance jom_chronoforms_data_application-form, and then prefix of the table changes and the name of the table becomes #__chronoforms_data_application-form
Just can't figure out why? Do I need to install Chronoconnectivity?
I can manually fix in table named _chronoengine_forms6 ("functions" column) but changes are not kept.
Thank you for your help
healyhatman 7
February 22 2019, 05:15 #384072
Is the prefix actually changing, or is it just DISPLAYED as #__ ? Because the "#__" is 'code' for Joomla to say "replace #__ with the prefix from the global settings"
Web developer at SkySpider.com.au - I DO NOT work for ChronoEngine!
Donations: paypal.me/healyhatman
Professional Work: kamron@skyspider.com.au
Custom CF / CC Plugins and Extensions: skyspider.com.au/store
G
glazweb 18
February 22 2019, 08:20 #384082
Thank you for your help, healyhatman.
Prefix is changing in the table and column I'm talking about. Table name is not changing
I can't display or manage entries because, in the form manager, I can only click on a link #__chronoforms_data_application-form. The result is an error message : 1103 Incorrect table name.
Here is a part of the "functions" column, in _chronoengine_forms6 Table :
{"_event":"submit","type":"save_data","name":"save_data3","label":"","enabled":"1","autotable":"1","model_name":"Data3","db_table":"#__chronoforms_data_application-form","data_provider":"","action":"save","insert_data_override":"created:{date:Y-m-d H:i:s}\r\nuser_id:{user:id}","update_data_override":"modified:{date:Y-m-d H:i:s}","autofields":"1","where":"","fields":{"special":""}
You can see that the prefix has changed.
I previously used CFV5. I uninstalled it, but tables used by CFV5 are still present in BDD. Could this be the problem ?
Thank you
healyhatman 7
February 22 2019, 08:24 #384083
No, apparently it's a known bug, will be fixed in the next update
Web developer at SkySpider.com.au - I DO NOT work for ChronoEngine!
Donations: paypal.me/healyhatman
Professional Work: kamron@skyspider.com.au
Custom CF / CC Plugins and Extensions: skyspider.com.au/store
G
glazweb 18
February 22 2019, 08:28 #384085
Ok, thank you.
Any idea on when the update will be released? My customer need to access daily to forms entries.
healyhatman 7
February 22 2019, 08:34 #384086
You can whip up a CCv6 Connection for the client to see their data in while you wait, should only take you a few minutes. Don't know when the update will be, you can also use an older download to go back a version.
Web developer at SkySpider.com.au - I DO NOT work for ChronoEngine!
Donations: paypal.me/healyhatman
Professional Work: kamron@skyspider.com.au
Custom CF / CC Plugins and Extensions: skyspider.com.au/store
G
glazweb 18
February 22 2019, 08:41 #384087
Thank you for this options / solutions.
Best regards
admin 27
February 23 2019, 15:49 #384125
 Answer
New update released to fix this!
Best regards
Max
If your main question got answered then please mark the answer using the button!
Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
G
glazweb 18
February 25 2019, 10:47 #384169
Thank you for the update!
Best regards.