Buy Now
Sign in

2checkout field "Product Provider"

michaelFFW , December 02 at 18:57
M
michaelFFW
Trying to find out what and format of items in the 2checkout redirect for the field "Product Provider".
I have tried a number of variations, but none work.
When I submit to 2CO I get my company name in heading so I know some info is correct.
But I get this error.
An error has occurred during checkout.
Please contact the seller and reference the error code below.
ERROR CODE:PE104
Stuck on what I am doing wrong.
Thank you.
Michael
healyhatman

​http://help.2checkout.com/articles/Knowledge_Article/Error-Code-PE104
Web developer at SkySpider.com.au
I don't work for ChronoEngine but I do accept donations paypal.me/healyhatman
M
michaelFFW
Hi, yes I found that link also.
Unfortunately it is not helpful, what I am looking for is the documentation on how to fill out the 2CO field "Product Provider.
healyhatman
Well you need to fill it out so that its value matches one of your 2CO product IDs. Is that not working? What have you tried?
Web developer at SkySpider.com.au
I don't work for ChronoEngine but I do accept donations paypal.me/healyhatman
M
michaelFFW
Hi, sorry for delay reply.
I setup a product in 2co.
The array in Product Provider that I used is just the product ID so only have that in it.
So it looks like this
1234567
Do I need something else in array?
healyhatman
If they'd not working try putting it in square brackets to make it an array maybe?
Web developer at SkySpider.com.au
I don't work for ChronoEngine but I do accept donations paypal.me/healyhatman
M
michaelFFW
My error in explaining.
The sample says this.
The products array provider, each array item is a product array which may contain the following values:
type,name,quantity,price,tangible,product_id,description,recurrence,duration,startup_fee
so 1234567 is product_id so I have in the space just 1234567.
So I dont really know how the format should be.
I tried entering ,,,1234567 and variations.
There really needs to be a better documentation. Actually there is none for the 2CO payment option.
healyhatman
Well then should probably be {"product_id":1234567} or ["product_id":1234567] I'll look into it later.
Web developer at SkySpider.com.au
I don't work for ChronoEngine but I do accept donations paypal.me/healyhatman
M
michaelFFW
Hi,
I tried variations of same. Nothing worked so far.
I appreciate you looking into this for me.
healyhatman
Set the "debug" parameter in your 2CO Redirect action to Enabled, put a debug action after it, and paste the results here.
Web developer at SkySpider.com.au
I don't work for ChronoEngine but I do accept donations paypal.me/healyhatman
M
michaelFFW
Hi
Here is the 2CO part of debug.
   [2co_redirect28] => Array
(
[products] => 3-Day Advanced Membership
[data] => Array
(
[mode] => 2CO
[sid] => 11111111
[currency_code] => USD
[purchase_step] => review-cart
)

[var] =>
)
healyhatman
OK so it looks like you've just put the NAME in the products provider, is that right? Instead of an array containing the product_id?
What's your product ID? From https://secure.2checkout.com/cpanel/products.php ?
Here's what my output looks like
    [2co_redirect3] => Array
(
[products] => Array
(
[0] => Array
(
[product_id] => 18406583
)

)

[data] => Array
(
[mode] => 2CO​
​ etc etc etc
I've created a 2CO account to try and help you but I don't get it you might have to use the Contact link up top and ask the dev for help.
Web developer at SkySpider.com.au
I don't work for ChronoEngine but I do accept donations paypal.me/healyhatman
healyhatman
OK I think I have it. You need to pass in an array containing MOST of the parameters.
So for example have a PHP block with
$product[] = ["product_id" => "18406583", "name" => "thename", "quantity" => 5, "price" => "5.00"];
And in your Products Provider put {var:phpname}
Web developer at SkySpider.com.au
I don't work for ChronoEngine but I do accept donations paypal.me/healyhatman
M
michaelFFW
Well I appreciate all your help, but nothing seems to work for me. No idea what I am doing wrong.
Debug
 [php32
  • => Array​
    ​ (​
    ​ [returned] => ​
    ​ [var] => ​
    ​ )​
    ​​
    ​ [2co_redirect28] => Array​
    ​ (​
    ​ [products] => ​
    ​ [data] => Array​
    ​ (​
    ​ [mode] => 2CO​
    ​ [sid] => 111111111​
    ​ [currency_code] => USD​
    ​ [purchase_step] => review-cart​
    ​ )​
    ​​
    ​ [var] => ​
    ​ )
  • This is php code in name php32
    $product = ["product_id" => "18368397", "name" => "3-Day Advanced Membership", "quantity" => 1, "price" => "40.00"];
    This is in Products provider field.
    {var:php32}
    In 2CO I have the product created. The SID and Hash of me must be correct as it shows my name if you turn debug off and let it continue to 2CO.
    One odd thing I just noticed, very top of debug page it says.
    Error getting the products list.
    So not sure if this is from array wrong or something with my identity.
    healyhatman
    Did you return $product in the PHP block?
    Web developer at SkySpider.com.au
    I don't work for ChronoEngine but I do accept donations paypal.me/healyhatman
    M
    michaelFFW
    Hi
    Of course I did not do that
    It works fine now.
    Thank you so much for helping and guiding me.
    Michael