Buy Now
Sign in

Recaptcha not working. Need urgent help!

baxterdown , November 01 at 16:52
baxterdown
Hi Bob,
I added a form to a new website and the Google nocaptcha keeps coming back with "The reCAPTCHA wasn't entered correctly. Please try it again." However, everything seems to be formatted correctly.
- I know it's not a server error because other CF5 forms on other websites are working ok.
- Its not the keys because the Google nocaptcha renders correctly
- Its not the form design or form setup because the form displays correctly
The form is located at http://www.gofastlife.com/gear
I just went live with the website, so I need urgent help!
Thanks in advance for your assistance,
Jose
GreyHead
Hi Jose,
Please try adding the full form Action URL in the HTML (render form) action and see if that solves the problem.
Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
baxterdown
Bob, thanks for the quick reply! I added it as http://www.gofastlife.com/gear. The form doesn't come back with an error any more but it doesn't submit either. It just loops back to the form.
What should I try next?
Jose
GreyHead
Hi Jose,
It needs to be the submit URL something like this http://www.gofastlife.com/index.php?option=com_chronoforms5&ChronoForms=form_name&event=submit
It's also possible that you need SSL for ReCaptcha.
Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
baxterdown
Hi Bob,
I went into CF control panel and test form, got this: http://gofastlife.com/index.php?option=com_chronoforms5&chronoform=gear and tested it, but that just redirects me to a page with just the form. So I copy/pasted the URL you have above and replaced ..."=form_name" with :=gear" and that yielded the following response: Form name can NOT be empty!
I know I don't need SSL because all my other forms on all other websites are working ok.
Jose
baxterdown
Would it be easier for you if I give you access to the site's control panel?
GreyHead
Hi Jose,
You need the &event=submit at the end to go to that event (otherwise you go to the load event).
Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
baxterdown
Hi Bob, I'm lost... :-( Can you post the URL I need so I can copy and paste?
Thanks!!!​
​​
​Jose
GreyHead
Hi Jose
Please try
http://gofastlife.com/index.php?option=com_chronoforms5&chronoform=gear&event=submit
Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
baxterdown
Thanks for the URL. Nothing, same error: The reCAPTCHA wasn't entered correctly. Please try it again. I also added it to another form on the site that is not in a module (thinking it could be because the form is in a module) and same issue.
What can we try next?
GreyHead
Hi Jose,
Does it work from the Test form or View form links in the Forms Manager?
Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
baxterdown
I doesn't. I tested both the Test and View options and same error. I went ahead and removed the Action URL from the contact form and tested it on both View and Test and same thing.
It's really strange because I am using the same version of CF (same file download) and the same Joomla template as the last website I designed and naturally the same ReCaptcha account.
I also just tried creating a new ReCaptcha to see if that would help and it didn't. Same issue.
Would you like me to give you access to the control panel?
Jose
GreyHead
Hi Jose,
Please double check the Google keys.
By all means PM me a login, it may be a little while before I can look as it's time for dinner here.
Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
baxterdown
Hi Bob,
I PMd you login info. Enjoy dinner. I'm off to the gym! :-) Catch up later.
Jose
healyhatman
Don't copy+paste from the forums, type it out manually. The forums often add hidden form-breaking characters
And you can't remove the action URL completely or it won't know where to send the form. Put it back to how it was, then right click your form in the frontend, inspect, look at the <form> tag and tell us what it says the action= attribute says.
Web developer at SkySpider.com.au
I don't work for ChronoEngine but I do accept donations paypal.me/healyhatman
baxterdown
Hi Bob,

​I just created a form on another website that doesn't use CF. So, I went through the installation and creating the keys on ReCaptcha, etc. The form works perfectly there. I'm stomped!
I added gofastlife.com to the new recaptcha I just created for testing on this other site and changed the keys on the contact form of the gofastlife.com site. I first saw the "owner error" when I went to the form, which said to me that the site wasn't yet able to validate the new recaptcha (all normal). I gave it a minute and refreshed the page and the recaptcha displayed correctly, which said to me it was now seeing the new keys. I completed and submitted the form and same error. UGH!
I have to go to a work function. I'll be home around 10:30pm EST. I'll come back then and look for any updates from you.
Thanks!
Jose
GreyHead
Hi Jose,
It evidently isn't working but I don't see any obvious problems. I suggest that for the moment you switch to use another captcha version.
I've taken a backup copy and will take a look at that in the morning.
Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
baxterdown
Hi Bob,
I GOT IT!!!! As I was driving home from the work event I kept trying to think what was different between this site and the other one where I created the test. Then I remembered that I had updated gofastlife's PHP to 7.1 because I didn't want the client to see the "Your PHP version, 7.0.32, is only receiving security fixes at this time from the PHP project..." warning in the control panel when I demoed the site.
I just got home and reverted the installation back to PHP 7.0 and bingo! The forms now work perfectly!!!
So... is there an issue with FC5 and PHP 7.1? Or is there anything I should adjust so the forms will work with it?
Thanks and talk in the morning!
Jose
GreyHead
Hi Jose,
Maybe something in the PHP settings - I restored your form on my test site running Joomla! 3.8.13 and PHP 7.2.11 and it works fine. The only changes I made were to replace your Recaptcha keys with mine, deleted the Action URL linked to your site and disabled the email to staff.
Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
baxterdown
Hi Bob, good morning.
Ok, I'm gonna check my server. I've heard that 7.1 was full of issues. I'm gonna try going straight through to 7.2. I'll update this post when I know more. Have a great day!!
Jose