Buy Now
Sign in

Cannot get created form to load without server timing out AND cannot save an edited form once it is opened

cyberspyder , September 19 at 17:57
C
cyberspyder
Running on Apache server with Joomla 3.8.12 and PHP 7.2. ​
​PHP vars set to max in ,htaccess. Have verified that there isn't a database issue or that it is maxing out db connections.
Hosted at Liquid Web Cloud servers. They've checked everything and are looking into it further, but it doesn't appear to be an issue on their end and we don't think so either.
After creating a job application form, when we try to open it for editing, the server times out. Eventually, we can get it to pen after several attempts over 5 minutes or so. Then, after making any edits, the form will never save and just sits on the saving page without ever showing as saved or closing.
We also have this form on a few other sites and can't even get it to open.
No errors generated in the server error logs and no messages other than timing out.​
​Any ideas where to go or what to check?
GreyHead
Hi cyberspyder,
Please check the Site Admin > System Info > PHP Info page to see what settings for max_input_vars and max_execution_time are actually in use on the site.
This FAQ might help.
Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
C
cyberspyder
Hello! Thank you for your help.
Our PHP is set to :
Maximum Input Variables 259200
max_execution_time 300
We have also already added this flag to the htaccess file: php_flag suhosin.simulation On as per another post. We did also try the suhosin values recommended in the FAQ, to no avail. We can't open the form, on the rare occasion we get it to open - we can't save any changes. There are no PHP errors in the log files.
GreyHead
Hi cyberspyder,
Can you take a form backup and post it here so that I can see if it opens OK on my test site.
Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
healyhatman
Cool but next time just use the "File upload" button.
Web developer at SkySpider.com.au
I don't work for ChronoEngine but I do accept donations paypal.me/healyhatman
C
cyberspyder
I looked all over for that.... where is it???
healyhatman
Web developer at SkySpider.com.au
I don't work for ChronoEngine but I do accept donations paypal.me/healyhatman
C
cyberspyder
GreyHead
Hi cyberspyder,
Please ignore: The form opens OK on my test server and I can edit and re-save it. It doesn't appear to be very complex:- 8 inputs (no submit button) in the Designer tab ; and only a Display Section action in the Setup tab.
Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
C
cyberspyder
Hmm. That is strange. I don't know what I did wrong, but here's the form front end. https://www.tacojakes.com/employment/
There are buttons on each page and it's got like 6 pages. The front end works the way we want it to, we just need to edit it, because they want to change all the dates from calendars to text blanks.
GreyHead
Hi Cyberspyder,
Ahhhh my apologies, I restored the wrong form download - mea culpa.
Yours restores but does not load in the editor: Fatal error: Maximum execution time of 30 seconds exceeded in . . .
It does look like a problem with servers settings because of the size of the form.
Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
C
cyberspyder
OK so what do we do about it? I have the server settings set to the suggested amounts. what can we do to make it more functional?
GreyHead
Hi cyberspider,
I suggest that you increase the max_execution_time setting until the form loads and saves correctly. If you temporarily set Site Error Reporting on then you can see the PHP error messages.
Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
C
cyberspyder
Hi GreyHead,
The server is set at the maximum. All recommended configurations were applied and it still would not work.
I was able to resolve the issue by doing the following:
1. I removed all the Save commands from the settings page.
2. I deleted the table from the database - not an issue since the there were no legit entries.
3. I was able to make my changes to the form and save normally.
4. I recreated the table
5. I added all the Save commands to the settings.
Now my form saves normally even with the database table connected. My assumption is - there was some corruption with the table after editing it repeatedly.
GreyHead
Hi cyberspyder ,
Well done - and thank you for letting us know. I have not seen a similar problem reported before.
Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much