Buy Now
Sign in

Calendar field not sending data as correct format

healyhatman , June 13 2018
Answered
healyhatman
My calendar field is set to Real Format: YYYY-MM-DD but it's sending the date as DD/MM/YYYY, which is the display format.
Array
(
[option] => com_chronoforms6
[chronoform] => new_timesheet-entry
[event] => submit
[button92] =>
[...........]
[manual_client] => 0
[client_job_code] => 1
[manual_job] => 0
[date] => 13/06/2018 <----------- RIGHT HERE
[start_time] => 1:00 AM
[finish_time] => 5:00 AM
[break] => 0
[total_hours_calculated] => 4
[next] => next
)
Web developer at SkySpider.com.au
I don't work for ChronoEngine but I do accept donations paypal.me/healyhatman

DON'T COPY+PASTE FROM THE FORUMS! It adds hidden code-breaking format characters!
healyhatman
OK I think I have it figured out. When you go back, it tries to fill the field with the data it already has, in this case it tries to put 2018-06-13 into the field and of course it comes up as 20/06/2013, with the value as 13/06/2018, if any of that makes sense.
Fixed by adding the extra attribute autocomplete:off
Web developer at SkySpider.com.au
I don't work for ChronoEngine but I do accept donations paypal.me/healyhatman

DON'T COPY+PASTE FROM THE FORUMS! It adds hidden code-breaking format characters!
admin
Thank you, this is added as a default extra attribute now!
Best regards,
Max
Max
If your main question got answered then please mark the answer using the button!
Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!