Buy Now
Sign in

CCv6 - SAVEor APPLY show error:You don't have permission to access /administrator/index.php on this server.

gix.vax , May 31 at 11:01
Answered
G
gix.vax
hi
i have a CCv6 form that show this error when i try to save or apply changes
You don't have permission to access /administrator/index.php on this server.
this happen only in SAVE or APPLY, when i use the form there's no problem
other forms in CF6 or connection in CCv6 works without problem
opening structure or using form on public side there's no problem, the form save data and work normally
but when i try to save or apply changes to structure it show this error.
This is a long form so i call hosting and ask them to put max_input_vars from 1000 to 5000 but doesn't work.
i reinstall CCv6 then CF6 (over existing CC/CF6)
no changes
if i backup form and modify in localhost with XAMPP there's no problem and if i put again online i have changes working but same problem saving and apllying changes
i don't know if is a permission or a security issue but other forms works
PHP 7.1.17​
​MySQLi 5.7.17​
​Joomla! 3.8.8 Stable ​
p.s.
in local and online i can't see Global configuration permission settings for CCv6, there's only for CF6.
is a bit urgent
thank you
GreyHead
Hi gix.vax,
This is probably a server or possibly an htaccess setting that is preventing access to the administrator folder. It's a bit odd because you need access to the administrator folder from the site admin which appears to be where you are seeing the problem :-(
Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
G
gix.vax
ok, but other forms doesn't have this problem​
​​
​i have access to htaccess and can ask my hosting to modify parameters (they are very fast)
GreyHead
Hi gix.vax ,
Do you have Custom Code in the form?
If you take a Form Backup using the icon in the Forms Manager and post it here then I'll take a closer look.
Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
G
gix.vax
ok, is here, thank you
p.s.
i'm changing the way file are uploaded so now i save in DB only filename but i'm modifying upload/download beahviour.
Custom code are for class fields in table (used in other forms) and to delete file with unlink (used in other forms too)
Repeat, if i open/use form there's no problem, the problem is only save and apply and only in this form.
Attachments
Ticket_docs_31_May_2018_16_26_54.c6bak
(17.34 KiB)
109 Downloads/Views
G
gix.vax
this is the error log from server
first 3 are when i accessed to the connection list
the last one is when i try to APPLY/SAVE
2018-05-31 18:26:54
Warning : Got error 'PHP message: PHP Warning: preg_replace() expects at least 3 parameters, 2 given in /var/www/vhosts/mysite.it/httpdocs/administrator/components/com_chronoconnectivity6/chronoconnectivity/controllers/connections.php on line 181\nPHP message: PHP Warning: preg_replace() expects at least 3 parameters, 2 given in /var/www/vhosts/mysail.it/httpdocs/administrator/components/com_chronoconnectivity6/chronoconnectivity/controllers/connections.php on line 183\n', referer: https://mysail.it/administrator/index.php?option=com_chronoconnectivity6&cont=connections2
018-05-31 18:35:27
Warning AH01071: Got error 'PHP message: PHP Warning: Invalid argument supplied for foreach() in /var/www/vhosts/mysite.it/httpdocs/libraries/cegcore2/admin/extensions/chronofc/themes/default/views/list-item.php on line 5\n', referer: https://mysail.it/administrator/index.php?option=com_chronoconnectivity6&cont=connections
2018-05-31 18:37:01
Warning AH01071: Got error 'PHP message: PHP Warning: Invalid argument supplied for foreach() in /var/www/vhosts/mysite.it/httpdocs/libraries/cegcore2/admin/extensions/chronofc/themes/default/views/list-item.php on line 5\n', referer: https://mysail.it/administrator/index.php?option=com_chronoconnectivity6&cont=connections
2018-05-31 18:40:21
Error ModSecurity: Access denied with code 403 (phase 2). Match of "rx (/install/index\\\\.php|/admin/fetch_data_af\\\\.php\\\\?action=create_txt_file_from_af_table$|/admin/structure/feeds/edit|^/([a-z]+/)?wp-admin/(?:admin|options-general)\\\\.php\\\\?page=wpsc-settings)"​
​ against "REQUEST_URI" required. [file "/etc/apache2/modsecurity.d/rules/tortix/modsec/50_plesk_basic_asl_rules.conf"]​
​ [line "114"] [id "340159"] [rev "36"] [msg "Protected by Atomicorp.com ​
​Basic Non-Realtime WAF Rules: Generic SQL inline command protection ​
​(MM)"] [data "concat("] [severity "CRITICAL"] [hostname "mysite.it"] ​
​[uri "/administrator/index.php"] [unique_id "hfgggggggggggggggggggggg"]
i edited sitename, IP and unique id
G
gix.vax
i ask my hosting to add an exception in mod_secure rules on ID 340159 and now work like a charm
I wait tomorrow and if you think there's nothing to add to this discussion i will mark this thread as answered.
for now, thank you
:-)
GreyHead
Hi giv.vax,
I don't immediately see anything else here - looks like you have fixed it :-)
Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
G
gix.vax
ok, thank you Bob