Buy Now
Sign in

Resize Issue for CCv6 Table View

har7801 , April 19 at 07:09
Answered
H
har7801
Has there been a solution or is there a reason why my CCv6 is going blank when resized for mobile view. This appears to only be happening with a 'Table' view.
All the other views work great. It's not a matter of how many columns are in there, even if I remove some it still does it.
Any help is welcomed.
Pics attached.
H
har7801
PicAll_good.JPGAll_Gone.JPG
Other_Views_Work.JPG
Attachments
All_good.JPG
All_good.JPG
(63.12 KiB)
54 Downloads/Views
All_Gone.JPG
All_Gone.JPG
(25.92 KiB)
76 Downloads/Views
All_good.JPG
All_good.JPG
(63.12 KiB)
60 Downloads/Views
All_good.JPG
All_good.JPG
(63.12 KiB)
75 Downloads/Views
Other_Views_Work.JPG
Other_Views_Work.JPG
(26.12 KiB)
78 Downloads/Views
H
healyhatman
Add this to a custom css and call it with {view:custom_css} (or whatever you name it).
@media only screen and (max-device-width: 480px) {​
​​
​ td.collapsing, th.collapsing {height: auto; }​
​ td.collapsing.right.aligned { text-align: left!important; }​
​}​
Web developer at SkySpider.com.au
I don't work for ChronoEngine but I do accept donations paypal.me/healyhatman
H
har7801
Thanks,
I have added the css to the 'Views' and am calling it first line in the 'Events' for 'Index' as this is the first event, but to no luck.
I did notice that it renders perfectly well into mobile size when i test the forms using the 'Preview' butoon from within the form creator or the 'Open' link from the main menu. This opens in the Joomla backend environment and not my front end view. Would my CSS of my pages be causing this issue then?
Can send any pics to assist. Just let me know.
H
healyhatman
yes because the backend end frontend use different templates.
Web developer at SkySpider.com.au
I don't work for ChronoEngine but I do accept donations paypal.me/healyhatman
H
har7801
Pics attached with Inspect from both my live site with the issue, and the live site but using preview button. It seems to be collapsing them to '0'. The data is there, and if I manually add the same size as the preview site it all comes good as can be seen from my doing in the attached.Live_Site.JPG
Attachments
Live_Site.JPG
Live_Site.JPG
(106.99 KiB)
69 Downloads/Views
Preview_Site.JPG
Preview_Site.JPG
(126.49 KiB)
47 Downloads/Views
H
healyhatman
Are you sure you put that custom CSS in the right spot?
Web developer at SkySpider.com.au
I don't work for ChronoEngine but I do accept donations paypal.me/healyhatman
H
har7801
All, got it all sorted.
Found that the bootstrap was delivering a '0' on the .collapsing height.
Entered a CSS and called the view in at the top of the table calling event.
CSS code is:
.collapsing {height: auto}
All fixed for all devices. All is right with the world again.
H
har7801
Thanks again healyhatman, you got me on the right track.