Buy Now
Sign in

CF4 empty actions when trying to edit a from

bubila , April 18 at 09:01
Answered
B
bubila
Hi guys
I have this problem and actually don't know what triggered it. Suddenly I cannot see what's inside my actions, whenever I try to edit a form all settings are empty, but I guess it's just a display issue, since the website is working perfectly. I guess this has something to do with Php, I get the preg_replace warning when switching to maximum error reporting and the difference I've noticed is in the left column where all actions are listed. If I use php5.6 they're shown correctly (but the form settings are still empty), then if I switch to php7 I see all actions listed without separations (you may see it in the back of the custom code settings popup) . No server logs that can help to figure it out, I've tried to install CF4 again but the result was worst, nothing worked and had to go back to this point.
Hope you may help me
thanks!
elisa
Schermata_2018-04-18_alle_10.51.05.png
elisa
GreyHead
Hi Elisa,
Maybe a CSS or PHP problem somewhere? - I have CFv4 running on Joomla 3.8.6 with PHP 7 without any obvious problems.
Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
B
bubila
Hi Bob
I also have other CF4 running on the same exact environment, and cannot guess what is going on, I've checked the server logs and also the console but no error is showing, it it's as if CF couldn't retrive data from the DB so nothing is shown inside. Looking deeper I found something strange.. I found two Chronforms component in Joomla but when I try to disable one nothing works anymore, how come I have two components? do you have any idea?
elisa
GreyHead
Hi Elisa,
I don't know how you get two CF copies running at the same time. It may be that there is a duplicate record in the Joomla Components table - but there can only be one set of component files.
You could try backing up your CF tables, uninstalling CF, remove any duplicate record in the Joomla Components table, then re-install CFv4 and restore the tables. That should not be necessary but if something is knotted up it may be the cleanest way to get it working again.
Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
B
bubila
Thanks Bob, I will try this solution you suggested
elisa
B
bubila
Hi Bob, just to let you know.. I've uninstalled CF4 as you suggested, then I had to manually delete the row in the database, in the extensions table, where there was the duplicated CF component, then I re-installed CF4 and restored the forms and all worked perfectly.
thanks
Elisa
elisa