Buy Now
Sign in

Reload

U Can Drive , April 15 at 22:31
Answered
U
U Can Drive
I'm having some problems with a basic "Switch" & "Reload" Event.​
​​
​I'm using a dropdown to select either "Yes" or "No" with an "Event" attached to cause "Results" to reload.​
​In the Setup area I'm using a "Switch" function to change the value of "Results" to either "You Bet" or "No Way"​
Problems:​
​1. While the Debugger shows the value is available it doesn't show in the "Results" box for the first attempt, maybe shows on the second or third change.
2. The whole page seems to reload not just the "Results" box.
https://ucandrive.com.au/index.php?option=com_chronoforms6&chronoform=testform
H
healyhatman
Are you maybe sending your reload event to your main Load event, instead of to a separate event? Got a screenshot of your Setup tab, and of the settings for the results and dropdown fields?
Web developer at SkySpider.com.au
I don't work for ChronoEngine but I do accept donations paypal.me/healyhatman
U
U Can Drive
Thank you for that, maybe, I've attached the setup view and the designer view of the relevant fields (at least what I think you need to see).
Attachments
Setup.png
Setup.png
(62.79 KiB)
44 Downloads/Views
Designer.png
Designer.png
(30.17 KiB)
45 Downloads/Views
H
healyhatman
https://www.chronoengine.com/faqs/74-chronoforms/chronoforms6/5299-how-to-reload-a-field
You need a separate event to perform the reload, not rerun the original load event.
Web developer at SkySpider.com.au
I don't work for ChronoEngine but I do accept donations paypal.me/healyhatman
U
U Can Drive
Thank you for that, I really do appreciate the help. I half know what I'm doing.​
​Now the Result field just disappears and there is no change to it's value.I have made a new event and put the "Switch" in there and the "Custom Code" as shown.​
Oops, sorry attached multiple times without realising.
Attachments
Setup.png
Setup.png
(40.43 KiB)
43 Downloads/Views
Designer.png
Designer.png
(20.77 KiB)
44 Downloads/Views
Setup.png
Setup.png
(40.43 KiB)
41 Downloads/Views
Designer.png
Designer.png
(20.77 KiB)
43 Downloads/Views
Designer.png
Designer.png
(20.77 KiB)
44 Downloads/Views
Setup.png
Setup.png
(40.43 KiB)
43 Downloads/Views
Designer.png
Designer.png
(20.77 KiB)
43 Downloads/Views
Setup.png
Setup.png
(40.43 KiB)
43 Downloads/Views
Designer.png
Designer.png
(20.77 KiB)
42 Downloads/Views
Designer.png
Designer.png
(20.77 KiB)
43 Downloads/Views
Designer.png
Designer.png
(20.77 KiB)
44 Downloads/Views
Setup.png
Setup.png
(40.43 KiB)
42 Downloads/Views
H
healyhatman
{view:field_text_2} in the custom code, not {view:view_field_text_2}
Is your custom event called Change?
Web developer at SkySpider.com.au
I don't work for ChronoEngine but I do accept donations paypal.me/healyhatman
U
U Can Drive
Yes it is called "Change", I had tried {view:field_text2} but that made no difference.
H
healyhatman
{data.set:Result$(var:Switch)}
{view:field_text_2}
Web developer at SkySpider.com.au
I don't work for ChronoEngine but I do accept donations paypal.me/healyhatman
U
U Can Drive
The new event
Attachments
Setupb.png
Setupb.png
(11.59 KiB)
42 Downloads/Views
U
U Can Drive
I copied that code into the custom code but has made no change. Still disapears and no change to the value.
U
U Can Drive
Actually, scrap that, it works perfectly on the actual page but not in the preview.
Thank you so much, I really appreciate your time