Buy Now
Sign in

SMTP authentification required

PeterK , April 14 2018
P
PeterK 5
April 14 2018 #377013
Building a Chronoform V6 in a website of a new provider I got the error message; "could not initiate mail function". The provider has checked the form and says that Chronoform cannot deal with their mandatory smtp authentification. Neither V5 nor V6 works whereas it works perfectly on servers of other providers. The provider says that Chronoforms tries to send the mail thru root@localhost which is not correct so he says. Can you help, please? Thanks.
Peter
Here is the log:
2018-04-14 12:04:59 CLIENT -> SERVER: EHLO www.la-union.net
2018-04-14 12:05:00 CLIENT -> SERVER: STARTTLS
2018-04-14 12:05:00 CLIENT -> SERVER: EHLO www.la-union.net
2018-04-14 12:05:00 CLIENT -> SERVER: AUTH CRAM-MD5
2018-04-14 12:05:00 CLIENT -> SERVER: aW5mb0BsYS11bmlvbi5uZXQgYjFmMzBhYTE0ZjVmOGIxNmM3OThmZTgyZGM4M2U3NDA=
2018-04-14 12:05:00 CLIENT -> SERVER: MAIL FROM:<root@localhost>
2018-04-14 12:05:00 CLIENT -> SERVER: RCPT TO:<webmaster@aie-eindhoven.nl>
2018-04-14 12:05:00 CLIENT -> SERVER: DATA
2018-04-14 12:05:00 CLIENT -> SERVER: Date: Sat, 14 Apr 2018 12:04:59 +0000
2018-04-14 12:05:00 CLIENT -> SERVER: To: webmaster@aie-eindhoven.nl
2018-04-14 12:05:00 CLIENT -> SERVER: From: Root User <root@localhost>
2018-04-14 12:05:00 CLIENT -> SERVER: Subject: sfghdfghfgh
2018-04-14 12:05:00 CLIENT -> SERVER: Message-ID: <fc54685f486b8d235a3b002b7ce1880a@www.la-union.net>
2018-04-14 12:05:00 CLIENT -> SERVER: X-Mailer: PHPMailer 5.2.26 (https://github.com/PHPMailer/PHPMailer)
2018-04-14 12:05:00 CLIENT -> SERVER: MIME-Version: 1.0
2018-04-14 12:05:00 CLIENT -> SERVER: Content-Type: multipart/alternative;
2018-04-14 12:05:00 CLIENT -> SERVER: boundary="b1_fc54685f486b8d235a3b002b7ce1880a"
2018-04-14 12:05:00 CLIENT -> SERVER: Content-Transfer-Encoding: 8bit
2018-04-14 12:05:00 CLIENT -> SERVER:
2018-04-14 12:05:00 CLIENT -> SERVER: This is a multi-part message in MIME format.
2018-04-14 12:05:00 CLIENT -> SERVER:
2018-04-14 12:05:00 CLIENT -> SERVER: --b1_fc54685f486b8d235a3b002b7ce1880a
2018-04-14 12:05:00 CLIENT -> SERVER: Content-Type: text/plain; charset=utf-8
2018-04-14 12:05:00 CLIENT -> SERVER: Content-Transfer-Encoding: 8bit
2018-04-14 12:05:00 CLIENT -> SERVER:
2018-04-14 12:05:00 CLIENT -> SERVER:
2018-04-14 12:05:00 CLIENT -> SERVER: Contactar el Webmaster
2018-04-14 12:05:00 CLIENT -> SERVER: Nombre:hfff
2018-04-14 12:05:00 CLIENT -> SERVER: Correo electrónico:kjghgh
2018-04-14 12:05:00 CLIENT -> SERVER: Teléfono:05450454
2018-04-14 12:05:00 CLIENT -> SERVER: Asunto:sfghdfghfgh
2018-04-14 12:05:00 CLIENT -> SERVER: Mensaje:dgfhdfghdfgh
2018-04-14 12:05:00 CLIENT -> SERVER: Anexo:
2018-04-14 12:05:00 CLIENT -> SERVER:
2018-04-14 12:05:00 CLIENT -> SERVER: IP: 178.249.155.130
2018-04-14 12:05:00 CLIENT -> SERVER:
2018-04-14 12:05:00 CLIENT -> SERVER:
2018-04-14 12:05:00 CLIENT -> SERVER: --b1_fc54685f486b8d235a3b002b7ce1880a
2018-04-14 12:05:00 CLIENT -> SERVER: Content-Type: text/html; charset=utf-8
2018-04-14 12:05:00 CLIENT -> SERVER: Content-Transfer-Encoding: 8bit
2018-04-14 12:05:00 CLIENT -> SERVER:
2018-04-14 12:05:00 CLIENT -> SERVER: <table>
2018-04-14 12:05:00 CLIENT -> SERVER: <tr><td><h1><strong>Contactar el Webmaster</strong></h1></td><td></td></tr>
2018-04-14 12:05:00 CLIENT -> SERVER: <tr><td>Nombre:</td><td>hfff</td></tr>
2018-04-14 12:05:00 CLIENT -> SERVER: <tr><td>Correo electrónico:</td><td>kjghgh</td></tr>
2018-04-14 12:05:00 CLIENT -> SERVER: <tr><td>Teléfono:</td><td>05450454</td></tr>
2018-04-14 12:05:00 CLIENT -> SERVER: <tr><td>Asunto:</td><td>sfghdfghfgh</td></tr>
2018-04-14 12:05:00 CLIENT -> SERVER: <tr><td>Mensaje:</td><td>dgfhdfghdfgh</td></tr>
2018-04-14 12:05:00 CLIENT -> SERVER: <tr><td>Anexo:</td><td></td></tr>
2018-04-14 12:05:00 CLIENT -> SERVER: <td></td></tr>
2018-04-14 12:05:00 CLIENT -> SERVER: </table><br /><br />IP: 178.249.155.130
2018-04-14 12:05:00 CLIENT -> SERVER:
2018-04-14 12:05:00 CLIENT -> SERVER:
2018-04-14 12:05:00 CLIENT -> SERVER:
2018-04-14 12:05:00 CLIENT -> SERVER: --b1_fc54685f486b8d235a3b002b7ce1880a--
2018-04-14 12:05:00 CLIENT -> SERVER:
2018-04-14 12:05:00 CLIENT -> SERVER: .
2018-04-14 12:05:00 CLIENT -> SERVER: QUIT
GreyHead 63.4
April 14 2018 #377014
Hi Peter,
As far as I know - and I am not expert in CFv6 - if you leave the From Email address empty in the Email action then ChronoForms will use the From Address from the site Email settings. I checked the code and I don't see anything that would set the From Email to root@localhost - unless that is set in the form somewhere.
Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
P
PeterK 5
April 16 2018 #377020
Thank you Bob,
This problems occurs both in CFv6 as wel las in CFv5. I just tried v6 to check whether the problem was the same. And it was indeed. You can see the problem bij filling and sending the form in http://www.la-union.net/index.php?option=com_chronoforms5&view=form&Itemid=206. As you suggested I left the 'from email' field empty but the error message keeps coming. I will be glad to give you the joomla administrator data if you are willing to check.
Thank you for your help.
Peter
GreyHead 63.4
April 17 2018 #377050
Hi Peter,
I saw this same header in a different site over the week-end :-(
The root@localhost address is a default setting in the class.phpmailer.php file (at line 73). If that is being picked up then I can only guess that somehow the Joomla From Email address is not being picked up. What is that set to in your site? - I wonder if that gives a clue.
Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
P
PeterK 5
April 17 2018 #377076
Hello Bob,
Sorry for my late answer, buzy day today :-)
Do you mean: Global configuration/server/Mail settings?
Send mail: yes
Disable mass mail: no
From email: info@la-union.net
From name: La Union
Reply to mail: (void)
Reply to name: (void)
Mailer: SMTP
SMTP host: smtp.mijnhostingpartner.nl
SMTP port: 25
SMTP security: none
SMTP authentication: Yes
SMTP username: info@la-union.net
SMTP password: (hidden) #info2015
These settings were checked by my provider and found OK. These settigs are equal to the configuration.php of the site. The test mail that can be sent here was OK and arrived OK. The provider concluded therefore that the error must be caused by the plug-in.
Hope this information helps.
Peter
P
PeterK 5
April 18 2018 #377081
Hello Bob,
I have tried the Joomla debugger. It says: Notice: Undefined index: mail in
E:\HostingSpaces\Union\la-union.net\wwwroot\administrator\components\com_chronoforms5\chronoforms\actions\email\email.php
on line 246: if($settings['mail']['mail_method'] == 'joomla'){
Maybe this gives you a clue?
Peter