Buy Now
Sign in

Chronoforms v6 and radiobuttons

Phil91 , April 12 at 13:52
Answered
P
Phil91
Hello GreyHead et al,
Was there during Forms v5 time and back now and trying v6...
Am building a form in which I added 2 radiobuttons without selecting a default value.
Turns out that when I test the form, whatever radiobutton I click stays selected. So, in this particular case, the 2 buttons I use get selected...
Have I suddenly become unfamiliar with Chronoforms or is it an "uncommented feature" :-) ?​
@GreyHead: Still in Brittany?
Cheers
Philippe
P
Phil91
Also: adding Google recaptcha, I got the following error msg when testing my form (removed the google key from image)
error.jpg
Thanks
Philippe
Attachments
error.jpg
error.jpg
(41.03 KiB)
55 Downloads/Views
error.jpg
error.jpg
(41.03 KiB)
78 Downloads/Views
GreyHead
Hi Philippe,
Greetings from sunny Finistere.
Not sure I understand your question about the radio buttons. Is the problem that you can't 'unselect' the group?
I suspect that the ReCaptcha problem may be because file_get_contents() is not enabled on the site?
Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
P
Phil91
Hi Bob,
It’s easy enough: I have set a radiobuttons group with, say, 2 buttons: when I test the form, I click option1 and set it, then I click option2 and set it: Both buttons get set. I would expect option 1 to be unselected but it’s not. What could I possibly mess up?
As far as file_get_contents, I’ll have to check with my hosting company I guess.
Cheers
Philippe
GreyHead
Hi Philippe,
When I test I can only select one radio button in the group. Please post or PM me a link to the form so I can take a quick look.
You can see the file_get_contents() setting on the Site Admin > System Info > PHP Info page.
Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
P
Phil91
Hi Bob,
I'm sorry: preview is here:
https://clubchevry2.com/sondage
as far as file_get_contents it's not visible anywhere...
However, when I run the command https://www.google.com/recaptcha/api/siteverify?secret=xxxxxxxx, everything works fine. Recaptcha is verified....So the question gets back to why does the command not work from the google_no_captcha_output.php file...
I thought that file_get_contents was standard php.....
Thx
Philippe
H
healyhatman
You've put the radio options in as separate fields.
Web developer at SkySpider.com.au
P
Phil91
@Bob: allow_url_fopen is enabled, so I don't know how to make file_get_contents work any better....
Will leave Google captcha out for now and use security images instead...
@Healyhatman:
Hmmm,
Not sure what you mean here: there's no way to add radio options as separate fields...
I inserted a radios group and defined 2 pairs in a horizontal layout as in the attached shot...
Where is the error?
Thxradios.jpg
Attachments
radios.jpg
radios.jpg
(32.74 KiB)
59 Downloads/Views
H
healyhatman
My bad I was looking at the html wrong. Have you given the field a name?
Web developer at SkySpider.com.au
P
Phil91
Nope...Will try with one...
P
Phil91
Cool, man!
This fixes it!
Surprising that I have to pick a name but as long as it works, that's all I need right?
Thx much!
Philippe