Buy Now
Sign in

Undefined index in mail.php

HerKle , April 09 at 11:19
HerKle
In administrator/components/com_chronoforms5/chronoforms/actions/email/email.php the line 246
 if($settings['mail']['mail_method'] == 'joomla'){​
delivers this php notice:
Notice: Undefined index: mail in [domain]\administrator\components\com_chronoforms5\chronoforms\actions\email\email.php on line 246
How can I fix this?
_______________________________
<STYLE> is poor man's basic right.
GreyHead
Hi HerKle,
The simplest way is to set your Site Error Reporting to System Default. PHP Notices are usually a nuisance, not a problem.
If you need to keep it at a high level then you could edit the code to check if 'mail' is set in the $settings array.
Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much