Buy Now
Sign in

facing issue in chronoform6 after creating form

directivemsp , April 02 at 14:15
D
directivemsp
Hello,​
​I am facing issue after creating form in chronoform6. i created form and tested it by view form so it is working fine but when i added form into module and assigned it on menu then it's not working. May be somewhere process is breaking please check the issue -
This is my form please check it.​
​Thank you
GreyHead
Hi directivemsp ,
I'm not clear why you would assign a module to a menu item? Does it work if you assign the form to a Menu item?
Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
D
directivemsp
Hello,
I am loading article on menu item and i want load chronoform module in sidebar so it's not working so please check it.
Thanks
GreyHead
Hi directivemsp ,
As you said - the form works correctly. The problem is most likely with the Action URL being set in the module. I suggest that you try over-riding the default URL in the form Display Section action https://domain_name.com/index.php?option=com_chronoforms6&chronoform=form_name&event=submit
It can also be helpful to enable the Ajax submission for forms in modules - provided that there are no file uploads.
Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
D
directivemsp
Hello,
I followed your instructions and i added action url in display section of form display action. Now form is working but email functionality is not working.​
​Thanks
Attachments
GreyHead
Hi directivemsp ,
The mail sends correctly when I remove the From Name and From Email settings that you have.
Bob
PS You also need to add an Event Loader action to the pink On Fail event of the Check Google ReCaptcha action.
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
D
directivemsp
Hello,​
​I followed the instruction which you told me but this is not working with this also.
getting error
https://prnt.sc/j3a0ys
but form is enable​
​i have override the url and removed From name and From email also.
please check i have added form here -
added event loader also
Thanks
Attachments
customer_feedback_10_Apr_2018_11_02_00.cf6bak
(11.23 KiB)
42 Downloads/Views
GreyHead
Hi directivemsp,
The form sends emails correctly when I test.
What is the URL when you get the form not found error?
Does the form work if you use the Preview button in the Forms Manager?
Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
D
directivemsp
Hello,​
​No actually issue is not that form is not sending email, when i load chronoform on module this condition form is not working this is a issue. Please check the issue with module, if you want then i can provide you demo account so you can check it.
Thanks
GreyHead
Hi directivemsp ,
If you have the form in a module the most likely problem is that it is not submitting at all.
Please try adding the form URL to the Action URL box in the ​
​https://domain_name.com/index.php?option=com_chronoforms6&chronoform=form_name&event=submit
replace domain_name.com and form_name with the correct values for your site.
Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
D
directivemsp
Hello,​
​I have tried with these instructions and which form i sent you so you can check that form also you can see the action url.​
​Thanks
D
directivemsp
Hello,​
​Have you checked the issue or got any issue ?​
​Thanks
GreyHead
Hi directivemsp,
The form worked when I tested so I can't replicate your problem here.
Please post a link to the form on your site.
Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much