Buy Now
Sign in

ChronosForms V5 Error In Backend: syntax error, unexpected '['

jpreville , March 14 at 02:13
J
jpreville
Hi,
I'm getting an error in ChronosForms V5 when clicking on the back end Administration.
I'm running PHP 5.3.16 (trying to get hosting to upgrade), Latest Joomla release (3.8.6).
There error is.
Parse error: syntax error, unexpected '[' in/usr/local/4admin/apache/vhosts/helpingourheroesmichigan.org/httpdocs/administrator/components/com_chronoforms5/chronoforms/chronoforms.phpon line152
If i comment out Line 152 and also 753 (Same Error) . It allows me to get into the component.
I'm not exactly what the variable on line 152 is for.
$tot = [];
Just trying to get an idea of were i should look to fix. I've been reading some other related posts. checking fields for that character ([). Only place i see it is in the Code Tab. In the formcode. In the class tages
class="validate['required'] 
Is that class tag suppose to have the closing " ?
Any help. Would be appreciated.
Thanks
John
GreyHead
Hi John,
I do not see $tot anywhere in the file on my test site. Please try upgrading to the latest release of CFv5.
Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
J
jpreville
Hi Bob,
Thanks for the reply. Just downloaded latest release. Installed it clean on my test site. It does have $tot=[];
In the administrator/components/com_chronoform5/chronoforms/chronoforms.php files is where you find it. Line 152.
John
GreyHead
Hi John,
My apologies, you are right.
I am not sure what that line is supposed to do - I think it is declaring $tot as an empty array. Please try replacing it with $tot = array(); and see if that fixes the problem.
Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
B
Bloomort
I have the same problem when I download V5.17. Running joomla 3.4
PHP Built On          Linux gator3068.hostgator.com 3.10.0-693.11.6.1.ELK.el6.x86_64 #1 SMP Tue Jan 23 10:30:30 MST 2018 x86_64        ​
Database Version      5.5.51-38.2        ​
Database Collation latin 1_swedish_ci        ​
PHP Version 5.3.29        ​
Web Server Apache        ​
WebServer to PHP Interface cgi-fcgi        ​
Joomla! Version Joomla! 3.4.5 Stable [ Ember ] 22-October-2015 21:30 GMT        ​
Joomla! Platform Version Joomla Platform 13.1.0 Stable [ Curiosity ] 24-Apr-2013 00:00 GMT        ​
User Agent Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:60.0) Gecko/20100101 Firefox/60.0      
"If i comment out Line 152 and also 753 (Same Error) . It allows me to get into the component. "
Do I just go and comment out the offending lines?
GreyHead
Hi Bloomort,
Please try the fix I suggested in my last post.
Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
B
Bloomort
Way too many problems trying to install Chronoforms let alone use it! I'll look somewhere else.
Tanks. I hope you fix your bugs
Be well!
B
Bloomort
Ignore this! I was just frustrated. If you update to Joomla V 3.8.8 and php V5.6, then Chronoforms_V5.0.17_Component.zip works perfectly well without any modifications to files.