Buy Now
Sign in

CSV Downloaded file - columns not properly aligned

kkurtz , February 20 at 14:10
Answered
K
kkurtz
I am able to download a csv file from one of my tables. But when I open the file in Excel the columns are not properly aligned. For example, if the record has not been modified then there is no date in "modified" and the columns after that in the record are moved over. If the record has been modified then the columns are all fine. I have tried to change the setting by going into the Modify Table page. I can't change the default setting for the table field and the Null column is always checked.
How can I get the columns aligned properly?
Thanks,
Karen
admin
Hi Karen,
some screenshots should help understand the problem better!
Best regards
Max
If your main question got answered then please mark the answer using the button!​
​Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
K
kkurtz
Max, thanks for getting back to me so quickly. I have attached three screen grabs: 1) showing what the Build Table screen looks like; 2) The table with data; 3) the CSV download of the table in Excel. As you can see the records with the modified date as null are shift one column to the left. The table was initially loaded using the MySQL add-in for Excel.​
​​
​My guess is that I can't fix this without reloading the table unless there is something I can do in phpmyadmin. If so please tell me. ​
​If I have to reload the table is it OK to empty it in phpmyadmin? ​
​Then when I reload with MySQL for Excel I will have to set the parm in Column Options to Allow Empty.
Thanks for your help,
Karen
cc6_build_table.JPG
cc6_infotable.JPG
cc6_infotable_csv_Excel.JPG
Attachments
cc6_infotable.JPG
cc6_infotable.JPG
(56.14 KiB)
140 Downloads/Views
cc6_build_table.JPG
cc6_build_table.JPG
(173.28 KiB)
124 Downloads/Views
cc6_build_table.JPG
cc6_build_table.JPG
(173.28 KiB)
109 Downloads/Views
cc6_infotable.JPG
cc6_infotable.JPG
(56.14 KiB)
104 Downloads/Views
cc6_infotable_csv_Excel.JPG
cc6_infotable_csv_Excel.JPG
(206.32 KiB)
110 Downloads/Views
cc6_build_table.JPG
cc6_build_table.JPG
(173.28 KiB)
162 Downloads/Views
cc6_infotable.JPG
cc6_infotable.JPG
(109.15 KiB)
174 Downloads/Views
cc6_infotable_csv_Excel.JPG
cc6_infotable_csv_Excel.JPG
(147.62 KiB)
166 Downloads/Views
GreyHead
Hi kkurtz,
What exactly is in the CSV file? You may be able to fix this by using the Data > From Text option in Excel as that gives you more control over the way the data is parsed.
Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
K
kkurtz
Hi Bob,
I tried the Data>From Text option and get the same result - the columns don't align properly.
I am attaching a ZIP of the CSV and Excel files with a sample of my data. When you open this in Excel you will see that the first record is aligned properly. But the 2nd and 3rd records are not. In the latter two records the modified field is null so everything after that is moved over one column. Nulls in the other columns don't seem to cause the same problem.
Thanks for your help,
Karen
Attachments
chronofile-csv.zip
(8.63 KiB)
57 Downloads/Views
GreyHead
Hi Karen,
I'm not familiar enough with CCv6 to have much idea what is causing this. I would expect the NULL entries to be included as empty strings in the CSV file - evidently that is not happening. Please ask Max to take a look using the Contact Us menu above and linking to this thread.
Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
admin
Hi,
There was a glitch affecting this and it should be fixed in the next update!
Best regards
Max
If your main question got answered then please mark the answer using the button!​
​Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
A
ataylor14
Admin
This id good as I have seen the same issue.
My post: https://www.chronoengine.com/forums/posts/t105614/csv-export-from-file-with-null-values-columns-shifted#377888
Please let us know when this is solved. Thank you!