Buy Now
Sign in

Send problem

polimaterica , January 28 at 10:24
Answered
P
polimaterica
Hi I have a problem with sending the form after the configuration in fact I always get the error:

Array
(
[email3] => Array
(
[result] => the Mail could not be sent.
[var] =>
)

)

If you can help me, thank you. Attached the configuration and the debug.
Attachments
Cattura.PNG
Cattura.PNG
(41.54 KiB)
100 Downloads/Views
configurazione_chronoform.PNG
configurazione_chronoform.PNG
(28.73 KiB)
102 Downloads/Views
GreyHead
Hi polimaterica ,

I can't see in either image what the From Name and From Email settings are - have you left them empty.

Also there is an 'Empty Body' error message at the top of one of the images that might be a clue.

Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
P
polimaterica

Array
(
[chronoform] => Preventivo small
[event] => submit
[NOME] => aaaaaaa
[CITTÀ] => bbbbbbbbbb cccccccccccccccc
[dati_preventivo] => ed id posuere nisi. Aenean non massa non elit eleifend varius vel et risus. Nulla facilisi. Curabitur aliquam, tortor non fringilla iaculis, sem lacus cursus velit, facilisis scelerisque turpis mauris a erat.
[info_mail__e_altro_] => Etiam pharetra pellentesque commodo. Nam vel nunc scelerisque, sollicitudin tortor ac, suscipit eros. Donec erat felis, viverra in dignissim id, blandit quis diam. In consectetur urna risus, in condimentum justo aliquam eget. Aliquam tempor urna a turpis vehicula semper. Etiam nec erat sollicitudin, condimentum eros vel, fringilla est. In elementum sit amet nibh sed iaculis. Praesent turpis quam, volutpat id nulla sit amet, suscipit semper ligula. Phasellus lectus sem, dignissim ut elit vel, laoreet elementum arcu. Integer facilisis fringilla bibendum.
[invia] => center
[option] => com_sppagebuilder
[view] => page
[id] => 6
[Itemid] => 101
[ark_inine_enabled] => 1
[arkoption] => com_sppagebuilder
)​
​​
Array
(
[email3] => Array
(
[result] => the Mail could not be sent.
[var] =>
)

)
errore_chronoform2018-01-31-16-26-21.png
Attachments
errore_chronoform2018-01-31-16-26-21.png
errore_chronoform2018-01-31-16-26-21.png
(57 KiB)
149 Downloads/Views
GreyHead

Hi polimaterica ,

I can see that the To and From Email addresses are the same - that will cause problem s with some mail services.

Bob

ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
P
polimaterica
2018-02-02-01-08-01003.png2018-02-02-01-08-0102.png

insert postmaster@ristrutturaresardegna.it

2018-02-02-01-08-0101.png

Attachments
2018-02-02-01-08-0101.png
2018-02-02-01-08-0101.png
(53.55 KiB)
81 Downloads/Views
2018-02-02-01-08-0102.png
2018-02-02-01-08-0102.png
(34.38 KiB)
82 Downloads/Views
2018-02-02-01-08-0102.png
2018-02-02-01-08-0102.png
(34.38 KiB)
82 Downloads/Views
2018-02-02-01-08-0101.png
2018-02-02-01-08-0101.png
(53.55 KiB)
133 Downloads/Views
2018-02-02-01-08-0102.png
2018-02-02-01-08-0102.png
(34.38 KiB)
139 Downloads/Views
2018-02-02-01-08-01003.png
2018-02-02-01-08-01003.png
(57.69 KiB)
133 Downloads/Views
GreyHead

Hi polimaterica ,

Does the Test Email link in the Site Admin > Settings page work OK?

Does the form work if you use the preview link in the Forms Manager (it looks as though you are embedding it in another component here)?

Bob

ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
P
polimaterica

Yes, it works

phpmail_conf2018-02-03-10-34-2902.png

mail received in php mail

phpmail_conf2018-02-03-10-34-2903.png

error in test with chronoform​
test_preview2018-02-03-10-34-29.png

test_preview2018-02-03-10-34-2902.png

Attachments
phpmail_conf2018-02-03-10-34-2902.png
phpmail_conf2018-02-03-10-34-2902.png
(17.4 KiB)
102 Downloads/Views
phpmail_conf2018-02-03-10-34-2903.png
phpmail_conf2018-02-03-10-34-2903.png
(17.38 KiB)
101 Downloads/Views
test_preview2018-02-03-10-34-29.png
test_preview2018-02-03-10-34-29.png
(53.57 KiB)
109 Downloads/Views
test_preview2018-02-03-10-34-2902.png
test_preview2018-02-03-10-34-2902.png
(32.79 KiB)
104 Downloads/Views
P
polimaterica

I inserted components only for the space ....

component_in_chronoform_2018-02-05-11-25-29.png

Attachments
component_in_chronoform_2018-02-05-11-25-29.png
component_in_chronoform_2018-02-05-11-25-29.png
(12.61 KiB)
103 Downloads/Views
admin

Hi polimaterica,

The email body is empty, and you have the "Auto add fields data" setting disabled as well, and so no email will be sent, please enable that setting or write something in the body!

Best regards

Max
If your main question got answered then please mark the answer using the button!​
​Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
P
polimaterica
Array
(
[chronoform] => Preventivo small
[event] => submit
[NOME] => aaaaaaaaaaaaa
[CITTÀ] => bbbbbb bbbbbb
[dati_preventivo] => Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Aenean commodo ligula eget dolor. Aenean massa. Cum sociis natoque penatibus et magnis dis parturient montes, nascetur ridiculus mus. Donec quam felis, ultricies nec, pellentesque eu, pretium quis, sem. Nulla consequat massa quis enim. Donec pede justo, fringilla vel, aliquet nec, vulputate
[info_mail__e_altro_] => Lorem ipsum dolor sit amet, consectetuer adinec, pellentesque eu, pretium quis, sem. Nulla consequat massa quis enim. Donec pede justo, fringilla vel, aliquet nec, vulputate
[invia] => center
[option] => com_sppagebuilder
[view] => page
[id] => 6
[Itemid] => 101
[ark_inine_enabled] => 1
[arkoption] => com_sppagebuilder
)

Array
(
[email3] => Array
(
[recipients] => Array
(
[0] => formcontattaci@ristrutturaresardegna.it
)

[subject] => Nuovo form completato da ristrutturaresardegna.it
[body] =>
[from_name] => formcontattaci
[from_email] => postmaster@ristrutturaresardegna.it
[result] => the Mail could not be sent.
[var] =>
)

)

P
polimaterica
Error without From email and From name. I do not think that the fact that it is in "com_sppagebuilder" should give problems.​
​I can try to publish it on another page in the forum.
Array​
​(​
​ [email3] => Array​
​ (​
​ [recipients] => Array​
​ (​
​ [0] => formcontattaci@ristrutturaresardegna.it​
​ )​
​​
​ [subject] => Nuovo form completato da ristrutturaresardegna.it​
​ [body] => ​
​ [result] => the Mail could not be sent.​
​ [var] => ​
​ )​
​)
GreyHead
Hi polimaterica ,
Please see Max's post earlier about the empty email body.
Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
P
polimaterica
Hi I had to create all the fields the autofield was not working anyway now it works, Thanks.
<p><img src="http://www.ristrutturaresardegna.it/images/bannerhome/mailpost.png" alt="" width="320" height="100" /></p>​
​<p>DATI DEL FORM</p>​
​<table style="margin-left: auto; margin-right: auto;">​
​<tbody>​
​<tr style="height: 68px;">​
​<td style="height: 68px;">​
​<p>NOME E COGNOME </p>​
​</td>​
​<td style="height: 68px;">{data:NOME}</td>​
​</tr>​
​<tr style="height: 14px;">​
​<td style="height: 14px;">&nbsp;CITTA</td>​
​<td style="height: 14px;">​
​<p>{data:CITTA}</p>​
​</td>​
​</tr>​
​<tr style="height: 28px;">​
​<td style="height: 28px;">​
​<div class="ui label green">dati preventivo</div>​
​</td>​
​<td style="height: 28px;">{data:textarea4}{data:dati1}</td>​
​</tr>​
​<tr style="height: 16px;">​
​<td style="height: 16px;">&nbsp;info mail e altro</td>​
​<td style="height: 16px;">{data:itextarea6}{data:dati2}</td>​
​</tr>​
​</tbody>​
​</table>​
​<p>&nbsp;</p>
P
polimaterica
screenshot-www.ristrutturaresardegna.it-2018-02-16-13-05-40.png
Attachments