Buy Now
Sign in

Problem with database and captcha

fabian85416 , January 22 at 20:02
Answered
F
fabian85416
Hi,

I've designed a relatively complex form with a database connection. So far so good. In my test environment it has worked well. Now, implemented on the website, it doesn't work anymore. I always get the message 'You have entered the wrong verification code!' - even if I enter the correct code.

I can't figure out my mistake....

The content here is visible only for authorized users.


Can you help me, please? Is that a known bug?

Regards,
Fabian
GreyHead
Hi Fabian,

I checked and the captcha code is being submitted correctly. Do you have caching enabled on the live site? that could affect it.

If you add a Debugger action before the Check Captcha and disable the check do you see the correct captcha code in the form data? (It might be simpler to check this on a little test form that doesn't require three file uploads).

Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
F
fabian85416
Hi Bob,

thanks for your quick answer. Caching is off. I'm gonna simlpify the form an add the debugger and see what happens...

Fabian
F
fabian85416
Hi Bob,

after deleting the 3 fileuploads and the 'redirect' at the end of the 'onSubmit' part the form seems to work properly. Debugger shows the correct captcha code.
I don't understand! Does the order of the elements cause the problem? Please, could you have a look on the screenshot attached?


Thanks for your help
Fabian
Attachments
screenshot-cf-setup.png
screenshot-cf-setup.png
(227.32 KiB)
72 Downloads/Views
F
fabian85416
Hi Bob,

the fileupload was obviously the bottleneck: I have no problem with one or two files. If I try to upload three files (this is the default setting), the form is emptied and I see the message 'You have entered the wrong verification code!'...

php.ini says:

php upload_max_filesize = 8M
post_max_size = 8M

8M wasn't enough for hires images! So, the problem had nothing to do with the verification code.

This is the solution. After changing the two php variables it works.
And sorry: No bug in chronoforms!

Thanks
Fabian