Buy Now
Sign in

Site that is in My Validations is showing Unvalidated on website

applebox , January 09 at 19:39
applebox
We are having two issues right now with a client of ours.
When we created a customized library for them, we were using ChronoForms v4 and ChronoConnectivity v4. When v5 came out there was no way for us to upgrade them because v5 didn't upgrade from v4 too smoothly. And we custom coded a lot of the microsite.

A few years back, they needed to upgrade their site from Joomla 2.5 to Joomla 3x. We did so but when we did this, we noticed that we were getting an error that say that ChronoForms and ChronoConnectivity were not validated. I checked in My Validations and sure enough they are there. However the license batch we purchased does not show up as an option (which chould be the reason we can't validate it).

Anyway, flash forward to October and the client said they cannot perform the functions like they could before with their forms. They are getting errors and the scripts aren't working properly. I reached out to you in October but never heard back. When I went to look into my messages now, all messages are gone. I'm assuming that's because you recently updated your website.

If I try to use the contact form for you now, it's not finding my Sales receipt number, so I can't complete the form. But if I go to My Validations, the numbers are all there.

Please help with this as soon as you can.

Michael M. Kadrie
Michael M. Kadrie
Vice President, Digital Media
Apple Box Studios
GreyHead
Hi Michael,

I'm not clear what your question is here?

If it is just about the validations please use the Contact Us menu above - while the Sale ID is helpful it is not required.

Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
applebox
Bob,
The problem is, the component is not recognizing that it is validated. I'm getting an error message that it's not validated.
I think the problem is that, we bought the validation key when you offered them as a single validation. Not a 3 or 5 or unlimited pack.
So there is no option for me to validate my key in the interface because those are the only three options. If I try to validate under any of those it won't do it. They are experiencing issues that weren't there before we updated the website to Joomla 3. So I'm not sure if the problem is that we are using v4 with Joomla 3 (which shouldn't be an issue) or if the issue is that the components are not validated. Which might be a likely reason.
Please see attached screenshots.

My second issue has to do with updating their website. We are going to be updating their website to a responsive design. It probably makes to update to the latest versions of ChronoForms and ChronoConnectivity. However, when I first looked into this, there was not quick upgrade solution. v4 didn't directly integrate to v5. My question is - has this changed? The code that we developed was a customized version of ChronoConnectivity and the database is large. When I tried to install v5 I got nothing but errors. So will we have to build the whole thing over again from scratch if we update to the latest version?

Thanks for your help with these.
Mike
Attachments
Screen_Shot_2018-01-15_at_5.06.17_PM.png
Screen_Shot_2018-01-15_at_5.06.17_PM.png
(16.2 KiB)
171 Downloads/Views
Screen_Shot_2018-01-15_at_5.06.51_PM.png
Screen_Shot_2018-01-15_at_5.06.51_PM.png
(42.82 KiB)
219 Downloads/Views
Screen_Shot_2018-01-15_at_5.07.59_PM.png
Screen_Shot_2018-01-15_at_5.07.59_PM.png
(34.71 KiB)
184 Downloads/Views
Michael M. Kadrie
Vice President, Digital Media
Apple Box Studios
GreyHead
Hi Mike,

Please contact Max using the Contact Us menu to ask about the validations - he should be able to resolve that for you.

The validation - or lack of it - should not cause any problem with the operation of the forms. There are some odds bugs that can arise using CFv4 on Joomla 3 but they are limited and have mostly been answered here.

There is no effective upgrade between CF versions. You can backup and restore but all that is transferred is the HTML and that retains the old classes etc, not the ones used in the new version.

Installing CFv5 or CCv5 should not cause a problem unless there is a mismatch in PHP versions or something similar.

Best wishes

Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
applebox
Thanks for your help Bob.
Michael M. Kadrie
Vice President, Digital Media
Apple Box Studios
applebox
Bob,
I've reached out to Max so hopefully we can get to the bottom of things.
But I have to go back to the actual problem that's happening and maybe you can help with that. There are a few problems that didn't exist when this was on Joomla 2.5 but are there with the latest version of Joomla 3.8.

We have a microsite for this client that has three different sections using CC and CF. A Library containing Audio, Sheet Music scans and Literature (just info and images). If you try to edit an entry that has an image upload associated with the data, you can't upload a new image. Or if it didn't have an image to begin with, it won't upload. The only time it will upload is when you create a new entry. This happens in all three sections. I checked the folder on the FTP and the image is just not being uploaded, but the database is being updated with the new image name.

The next problem is that, all three sections are set up the same, but only one of the sections (the Literature Library) gives you the ability to Delete the entry with a "Delete" link right next to the entry. All of the others do not have that but the settings are exactly the same. And they all have a checkbox to "Edit/Delete" in bulk but no button showing to execute the command. You can edit one at a time by clicking on the title and that takes you to the edit page.

The last item is based on what the client has said but I have not been able to duplicate it (still worth asking).
The client says that entries to the Audio Library duplicate and are taking file numbers that can’t be used again. I'm just throwing that one out there in case you know what could be going on. I'm waiting for them to verify this.

I know this is a lot, but there appear to be many issues right now.

Thanks,
Mike
Michael M. Kadrie
Vice President, Digital Media
Apple Box Studios
GreyHead
Hi MIke,

I'm assuming that these are problems with the CFV5 versions?

Editing file uploads needs some careful management - you can't just treat that like a text input. Please see this FAQ which was written for CFV4 but afaik the same principles work for CFv5.

If you temporarily add Debugger actions to the form (or to a copy of it) you should be able to diagnose what is happening with the missing uploads.

The Edit/Delete button problem sounds as though there might be some CSS hiding the button. Checking the page HTML should let you see if that is the case.

I have no idea about the duplicate Audio Library entries except to suggest that you use the Debugger to check through the logic of what is happening.

Best wishes

Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much