Buy Now
Sign in

Can't add new model

megana , December 28 2017
m
megana

Hi there, we have been using CF6 on a site for a while but just added CC6. I followed the FAQ to set up a basic listing but I got stuck on "Part 4: Retrieving data from more tables".

https://www.chronoengine.com/faqs/73-chronoconnectivity/chronoconnectivity-v6/5283-build-a-basic-listing

Part 4: Retrieving data from more tables
In part 4 we will show how you can create a simple table relationship to get the article's author username and display it in the table.

1. Open the connection and go to "Functions" > "read_articles".
2. Write "Author" in the "New model" box and click the "Add new model" button.
3. Wait for the new model to be added and then click the new "Author" label in the models menu to open the new model's settings section.



After I click "Add new model", the spinning loading graphic appears and never goes away.

The console shows me some JS errors...

				Uncaught TypeError: undefined is not a function
at forEach (<anonymous>)
at Function.forEach (mootools-core.js?680383c6c1a13fed6a6be67d7729a748:5)
at each (mootools-core.js?680383c6c1a13fed6a6be67d7729a748:9)
at e (jquery.min.js?680383c6c1a13fed6a6be67d7729a748:4)
at dc (jquery.min.js?680383c6c1a13fed6a6be67d7729a748:4)
at Function.n.param (jquery.min.js?680383c6c1a13fed6a6be67d7729a748:4)
at Function.ajax (jquery.min.js?680383c6c1a13fed6a6be67d7729a748:4)
at read_data_add_model (index.php?option=com_chronoconnectivity6&cont=connections&act=edit&id=1:2236)
at HTMLButtonElement.onclick (index.php?option=com_chronoconnectivity6&cont=connections&act=edit&id=1:2289)


What's going on here and how do I fix it?

Joomla 3.8.3
PHP 5.6
CF 6.0.15
CC 6.0.6

m
megana

Still having this problem, any advice?

GreyHead

HI megana,

It's possible that the problem is because MooTools is loading on the site and getting in the way of the jQuery code. Neither CF, CC or Joomla! 3.8 use MooTools any more.

Bob

ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much

m
megana

Hi Bob,

I tried all three admin templates in case one doesn't load mootools, but all had the same error. Is there a way to prevent Joomla admin from loading mootools? Or I'm wondering what my Joomla admin is doing differently from everyone else's.

Thanks,
-Megan

GreyHead

Hi Megan,

Sorry I have no idea why your site would load MooTools. I think that the jQuery Easy extension includes a MooTools blocker - you could try that if you can't work out what is loading it for you.

Bob

ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much