Buy Now
Sign in

Repeater Tutorial - Example?

jjspelman , November 08 at 21:48
j
jjspelman

I am trying to rebuild nearly a dozen forms because my custom tables data is not being sent in emails and not being saved to the data base.

I am trying to take advantage of the Repeater function by allowing users to add additional information if needed. for example, on the sample form here, You can see the old Table below Specifications. I want to create an "Area" that contains all the fields necessary to complete one item information submission, and if they have additional items, to simply click Add another item, and the same 8 fields are then repeated for the additional item(s).

I am obviously missing something here because when loading the form, the initial area with the 8 fields are not even showing on the page. They do not show until you click Add another item button.

I also need to make certain these fields will be included in all emails and written to the database, which i believe it will because it is generated by ChronoForms and not a custom table.

isn't there a video tutorial or something to show how to do this? I am NOT a programmer by any stretch and am lost when I start reading about arrays and things. Can someone please help? I have been struggling with these forms since trying to rebuild them in V6 - they were all originally custom html brought into Chronoforms.

j
jjspelman

Guys I really need assistance here. I will pay if need be. Please help!!

j
jjspelman

I tested the form and I am not getting info on repeatable items. It only shows the first set of information. If I click "add another item", and complete the fields, they do not show up in the email notification. The subsequent item info is also not showing up in the database save.

admin

Hi jjspelman,

Yes, you will need to use a Loop.

Please add a debugger to the form submit event and post the debug results here so I can give you some hints on the configuration needed.

Best regards

Max
If your main question got answered then please mark the answer using the button!

j
jjspelman

#message removed because it contained private info

admin

Hi JJ,

I have removed your message text because it had some private info which is better not published on the forums.

it does not look like you have setup the repeater fields names correctly, please post a screenshot of the repeater area in your form so I can check the fields names.

Best regards

Max
If your main question got answered then please mark the answer using the button!

j
jjspelman

I think this would go a lot quicker if you just told me how to use this feature. :) I also sent you admin info so you could actually log in and see what I was trying to do instead of me trying to send you screenshots and hoping I get it right and hoping even more than I get a timely response. I know you guys are busy but this is creating issues with my client who is tired of excuses. not your fault but I need to resolve this yesterday.

Attachments
Screen_Shot_2017-11-15_at_4.28.42_PM.png
Screen_Shot_2017-11-15_at_4.28.42_PM.png
(152.28 KiB)
36 Downloads/Views
admin

Hi JJ,

The problem here is your fields names, the fields should send array of data, so instead of "container_size" you would need something like "model[#area_repeater96.count][container_size]" to be converted to an array when the repeating button is clicked and the element is cloned.

This is an important setup step which is explained in the manual.

Best regards

Max
If your main question got answered then please mark the answer using the button!