Buy Now
Sign in

Checkboxes with multiple selection - Hebrew charactars get messed up when saved to DB / manually added to email, but not when auto added to email

yorai85 , October 29 at 14:41
y
yorai85

hello there.

on 1 of my forms there's a multiple-selection checboxes.
i'm attaching screenshots of the full settings area of that field.

when saved to the DB, the hebrew character from the field's value turns into codes like "\u05e9\u05d9\u05e8\u05d5\u05ea".
also , when manually added to the content of an email (with the {data:field_name} short code, the same error occures.

but - when using the option "Auto add fields data" in the email's settings - the content of that checkboxes is passing as expected.

when i tested an email with both "auto add" an manually add, the auto-added showed the correct values, but the manually added showed the mentioned codes.
please see an attached screenshot of the email content.

i tested several different configuration of the email function & the chekboxes field's settings, as well as different options for the form itself (like disabling the Ajax submit). all produced the same error.

can you please advise how to solve this issue?

thank you very much
yorai

vesion information:
chronoforms 6.0.12
joomla 3.8.0
DB version 5.5.56-cll-lve
PHP version 7.0.24

Attachments
email-content-auto-vs-manual.png
email-content-auto-vs-manual.png
(25.22 KiB)
16 Downloads/Views
checkboxes-settings-1.png
checkboxes-settings-1.png
(23.62 KiB)
15 Downloads/Views
checkboxes-settings-2.png
checkboxes-settings-2.png
(17.26 KiB)
19 Downloads/Views
checkboxes-settings-3.png
checkboxes-settings-3.png
(15.96 KiB)
15 Downloads/Views
checkboxes-settings-4.png
checkboxes-settings-4.png
(14.76 KiB)
14 Downloads/Views
checkboxes-settings-5.png
checkboxes-settings-5.png
(9.9 KiB)
15 Downloads/Views