Buy Now
Sign in

Chronoform v5 - external DB

m.deig , October 18 at 08:37
m
m.deig

Hi,

I need to save data in an external DB ( subdomain). I correctly set all fields in DB SAVE - External DB: so I can see all tables from external DB. And I choose the one I need to write in. And I enable the action.
But in wizard view it says that the action is disable and there is no table set.

Please note: In DB SAVE - Tab Basic I set Disable and I choose no table because I cannot see external table from there.

Can you explain where is my mistake?

Thank!!!

GreyHead

Hi m.deig,

Please enable the action on the Basic tab and leave the Table Name empty.

Bob

ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much

m
m.deig

Thanks Bob, but if I do so it gives an error for table not set.

If you try, do you get a different response?

Miriam

GreyHead

Hi Miriam,

The Enable/Disable works for the whole action so it must be Enabled to work.

The Table name on the first tab should be left empty but you should add the remote table name on the External tab. If you don't see a list of tables there maybe the database is not accessible.

Bob

ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much

m
m.deig

Hi Bob,

I did exactly as you said:
- I connect to the external DB
- I can see the table in the External Database dropdown
- I choose the table I need from dropdown
- If I save and close the same table is still set in dropdown

But still I got the errors Table not set.

Where am I wrong?

m
m.deig

Hi,
any advice?

Thanks

Miriam