Buy Now
Sign in

"1064 - You have an error in your SQL syntax;" error after update J2.5.28 to J3.8.0 and 4.0 RC3.4.1 to V4.0.7

GixxerMKD , October 03 at 12:11
G
GixxerMKD

Hi guys,

i have updated my site running Joomla 2.5.28 to Joomla 3.8.0 and i've updated ChronoForms 4.0 RC3.4.1 to V4.0.7.

Now on some of the forms (not all of them) i get 1064 db error. I've tried hitting the "Apply all the latest Chronoforms Database updates:" but i get: Applied '0' Database updates successfully.

I've enabled the error reporting on the site so when i hit this button i see:
Strict Standards: Non-static method ChronoFormsDbUpdates::updateDB() should not be called statically in /website.com/upgrade/administrator/components/com_chronoforms/controller.php on line 122

on the front end on some forms i see:
"1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '<font color=ff0000> Strict Standards: Only variables should be assigned by refer' at line 1"

on other its just:
"1064 - You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '' at line 1"

while other show up fine.

Any idea what might be the problem or how can i fix it?

thanks

GreyHead

Hi GixxerMKD,

It looks to me as if the Strict Standards warning message may be causing the MySQL error. Please try turning off error reporting or setting it to a lower level and see if the forms then display correctly.

Bob

ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much

G
GixxerMKD

Hi Bob,

thank you for the reply.

The StrictStandards is just a notification as you know, it's not a fatal error, i've deliberately enabled the error reporting to try to find what's causing the error but it's only that. Disabling the error reporting changes nothing on the front-end.

Private content
The content here is visible only for authorized users.

admin

Hi,

The error usually means an empty SQL query, do you have any database actions in the load event of the form with the problem ?

Since you have v4 you will need to have either the curl function enabled on the server in order to be able to validate Chronoforms.

Best regards,
Max

Max
If your main question got answered then please mark the answer using the button!

G
GixxerMKD

Hi Max,

i've just noticed that on some of them i get the following error, both on back-end and front-end:

Table 'dbname_AddressContactNo' doesn't exist

that's strange because on the live site the same form functions fine. On the staging site as i've said before i've updated the chronoforms 4.0 RC3.4.1 to V4.0.7 and joomla.

Can you please advice me how can i fix this?

admin

Hi GixxerMKD,

No idea, is it possible to install v6 on the same website and use it to build this form only ? v4 is not developed anymore.

Best regards

Max
If your main question got answered then please mark the answer using the button!