Buy Now
Sign in

CF6 Database connection failed

Chris1984NRW , September 21 2017
Answered
C
Chris1984NRW

any idea?

admin

Hi Chris,

Please post a screenshot of your current read_data settings

Best regards

Max
If your main question got answered then please mark the answer using the button!​

Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
C
Chris1984NRW

db_data_failure.JPG

Attachments
db_data_failure.JPG
db_data_failure.JPG
(84.11 KiB)
88 Downloads/Views
C
Chris1984NRW
I got this failure also when i Delete the new where clause
C
Chris1984NRW

I fix it. Here are the new db_data:

db_data_failure.JPG

Attachments
db_data_failure.JPG
db_data_failure.JPG
(63.94 KiB)
81 Downloads/Views
C
Chris1984NRW

Now I get an empty site. No fields shown

admin

Hi Chris,

The error notes that no "aktiv" field exists in the table, so adding "spiel" is not supposed to solve it, do you have "aktiv" placed in other settings ?

Best regards

Max
If your main question got answered then please mark the answer using the button!​

Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
admin

Hi Chris,

The error notes that no "aktiv" field exists in the table, so adding "spiel" is not supposed to solve it, do you have "aktiv" placed in other settings ?

Best regards

Max
If your main question got answered then please mark the answer using the button!​

Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
admin

Hi Chris,

The error notes that no "aktiv" field exists in the table, so adding "spiel" is not supposed to solve it, do you have "aktiv" placed in other settings ?

Best regards

Max
If your main question got answered then please mark the answer using the button!​

Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
C
Chris1984NRW
aktiv exists in the db. See the Picture in this Thread from my db structure.
Why i get an empty site when i set the following where condition:
spiel:{data:field_select1}
aktiv:1
admin
Hi Chris,
Your select type is set to "first matching" ? what happens when you use the first condition only:
spiel:{data:field_select1}
Best regards
Max
If your main question got answered then please mark the answer using the button!​

Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
C
Chris1984NRW
Hi Max
the same result. Empty site
admin
Hi Chris,
Empty site mean a full blank page or an empty list/form ? does the debug show any info ?
Best regards
Max
If your main question got answered then please mark the answer using the button!​

Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
C
Chris1984NRW
Hi Max,
empty form. The Joomla site would shown. But not the form.
Debug at the start in db_read_data_25 in the sector found dont shown
admin
Hi Chris,
Please add a debugger just after the "Read data" what are the results displayed ?
Best regards
Max
If your main question got answered then please mark the answer using the button!​

Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
C
Chris1984NRW
I set a Debugger in the not found sector:
[read_data25] => Array​
​ (​
​ [log] => Array​
​ (​
​ [0] => SELECT COUNT(`auswaertsspiele_einstiegsorte`.`spiel`) AS `auswaertsspiele_einstiegsorte.count` FROM `bvbsups_auswaertsspiele_neu` AS `auswaertsspiele_einstiegsorte` WHERE `auswaertsspiele_einstiegsorte`.`spiel` = '' AND `auswaertsspiele_einstiegsorte`.`aktiv` = '1';​
​ [1] => SELECT `auswaertsspiele_einstiegsorte`.`einstiegsort1` AS `auswaertsspiele_einstiegsorte.einstiegsort1`, `auswaertsspiele_einstiegsorte`.`einstiegsort2` AS `auswaertsspiele_einstiegsorte.einstiegsort2`, `auswaertsspiele_einstiegsorte`.`einstiegsort3` AS `auswaertsspiele_einstiegsorte.einstiegsort3`, `auswaertsspiele_einstiegsorte`.`einstiegsort4` AS `auswaertsspiele_einstiegsorte.einstiegsort4` FROM `bvbsups_auswaertsspiele_neu` AS `auswaertsspiele_einstiegsorte` WHERE `auswaertsspiele_einstiegsorte`.`spiel` = '' AND `auswaertsspiele_einstiegsorte`.`aktiv` = '1' LIMIT 100;​
​ )​
​​
​ [var] => ​
​ )​
​​
​ WHERE `auswaertsspiele_einstiegsorte`.`spiel` is empty. this is the Problem. But how can I fix this?​
​​
admin
Hi Chris,
Sorry, the {data} should be {data:select1} because you should use the field name inside the tags.
Best regards
Max
If your main question got answered then please mark the answer using the button!​

Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
C
Chris1984NRW
Hi Max,

​that doesnt fix it
admin
Hi Chris,
There is no guarantee that this will fix it, but how was the debug changed with this change ?
Best regards
Max
If your main question got answered then please mark the answer using the button!​

Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
C
Chris1984NRW
[read_data25] => Array​
​ (​
​ [log] => Array​
​ (​
​ [0] => SELECT COUNT(`auswaertsspiele_einstiegsorte`.`spiel`) AS `auswaertsspiele_einstiegsorte.count` FROM `bvbsups_auswaertsspiele_neu` AS `auswaertsspiele_einstiegsorte` WHERE `auswaertsspiele_einstiegsorte`.`spiel` = '' AND `auswaertsspiele_einstiegsorte`.`aktiv` = '1';​
​ [1] => SELECT `auswaertsspiele_einstiegsorte`.`einstiegsort1` AS `auswaertsspiele_einstiegsorte.einstiegsort1`, `auswaertsspiele_einstiegsorte`.`einstiegsort2` AS `auswaertsspiele_einstiegsorte.einstiegsort2`, `auswaertsspiele_einstiegsorte`.`einstiegsort3` AS `auswaertsspiele_einstiegsorte.einstiegsort3`, `auswaertsspiele_einstiegsorte`.`einstiegsort4` AS `auswaertsspiele_einstiegsorte.einstiegsort4` FROM `bvbsups_auswaertsspiele_neu` AS `auswaertsspiele_einstiegsorte` WHERE `auswaertsspiele_einstiegsorte`.`spiel` = '' AND `auswaertsspiele_einstiegsorte`.`aktiv` = '1' LIMIT 100;​
​ )​
​​
​ [var] => ​
​ )​
​​
​)