Buy Now
Sign in

Plugin after installation Joomla 3.8.0 no longer works when using Security Image

Peter48 , September 20 2017
Answered
P
Peter48
After updating from Joomla 3.7.5 to 3.8.0, the forms with Security Image no longer work. By selection of the correct image, the error message always shows that the wrong image was selected (see attachments).

When using the same form without Security Image, the processing is correct.

For the test, i was using the basic contact form (see attachments).

Note: This is only true if the form is called by means of plugin {chronoforms6} xxxxxx {/ chronoforms6}. When developing under Forms Manager, "preview" and/or "view" the error can not be produced!

Heeeeeeeeelp!
Attachments
2017-09-20_error_security_image.jpg
2017-09-20_error_security_image.jpg
(46.02 KiB)
706 Downloads/Views
P
Peter48
In addition to the previous error message, the use of the form by module does not work either!
P
Peter48
Additionally i found that when writing the form data into a database, using the plugin, the entries are written 2 times.

Also the emails are written 2 times and sent!!
admin
Hi Peter,

Any issues occurring under the plugin mode only are usually related to the Joomla caching, you can either turn it off or set the form "Action url" to {url:} which will send the form data to the default form submission page.

Best regards,
Max
Max
If your main question got answered then please mark the answer using the button!​
​Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
P
Peter48
Hi Max

Thanks for the answer.

Joomla caching is (was) turned off. Nevertheless,
- emails
- Database entries
ar written two times and the
- Security Image
does not work either.

I have just installed 2 new basic installations of Joomla and the errors can be only "produced" under the joomla version 3.8.0. With the version 3.7.5 there ar no problems.

Joomla version 3.7.5
- Chronoforms 6.0.9
- emails: ok
- database insert: ok
- security images: ok

Joomla version 3.8.0
- Chronoforms 6.0.9
- emails: send two twice
- database insert: insert twice
- security images: does not work (error message: You didn't select the correct image)

Best regards,
Peter
admin
Hi Peter,

Do you have any extra "plugins" installed on the 3.8 ? could you please turn off all system and content plugins before running a new test ?

Best regards,
Max
Max
If your main question got answered then please mark the answer using the button!​
​Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
P
Peter48
Hi Max

Both test installations (3.7.5 and 3.8.0) are basic installations without additional software, exception of
- Chronoforms_V6.0.9_Extension.zip
- plg_chronoforms6.zip
- mod_chronofroms6.zip

I did the tests with the exclusion of all system and conten plugins, but the emails and the database entries were still duplicated.

Just noticed that under Joomla 3.8.0 also e-mails created with forms version 5 of Chronoforms are now sent twice.

Best regards,
Peter
S
STUBRBS
Same issue here, but with Chronoforms v4. On all installations: captcha is no longer validated. With J3.7.5 this was no problem, with v3.8 this stopped working.
Could you please help?

Regards
Bernhard
admin
Hello,

I could not replicate the issue here on Joomla 3.8, neither using the forms manager link nor using the plugin, please add a debugger action to the end of the "submit" event and post the debug results.

Best regards,
Max
Max
If your main question got answered then please mark the answer using the button!​
​Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
admin
Hi,

This looks like an issue with the latest Joomla update:
https://issues.joomla.org/tracker/joomla-cms/18066

Best regards,
Max
Max
If your main question got answered then please mark the answer using the button!​
​Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
S
STUBRBS
So this means it will be fixed with v3.8.1?

Regards
Bernhard
admin
Hi Bernhard,

I think so, but we do not have control over this here, we can only update Chronoforms.

Please try to disable the form relative url setting, this may help solve the issue.

Best regards,
Max
Max
If your main question got answered then please mark the answer using the button!​
​Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
S
STUBRBS
Hi Max
Thanks a lot for your help. I will do this.

Regards
Bernhard
P
Peter48
Hi Max

After the update of Joomla 3.8.0 to 3.8.1, all my problems described in this error message
- Verification Security Images
- Duplicate creation of emails and DB updates
appear to be solved. Apparently, all errors related to a faulty Joomla update Version 3.8.0.

Thanks for your efforts and best regards
Peter
R
renierjvr
I have the latest Joomla update (3.8.1) with a RocketTheme template, and yet I still get the same issues:
1. Security Images not functioning.
2. Double email being sent.
How do I resolve that?


Setting:  Value
PHP Built On  Linux www508.jnb2.host-h.net 3.16.0-4-amd64 #1 SMP Debian 3.16.43-2+deb8u5 (2017-09-19) x86_64
Database Version  5.5.5-10.0.32-MariaDB-1~wheezy
Database Collation  utf8_general_ci
Database Connection Collation  utf8mb4_general_ci
PHP Version  5.6.30-0+deb8u1
Web Server  Apache
WebServer to PHP Interface  cgi-fcgi
Joomla! Version  Joomla! 3.8.1 Stable [ Amani ] 4-October-2017 14:00 GMT
Joomla! Platform Version  Joomla Platform 13.1.0 Stable [ Curiosity ] 24-Apr-2013 00:00 GMT
User Agent  Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/61.0.3163.100 Safari/537.36
Attachments
01.png
01.png
(31.27 KiB)
465 Downloads/Views
GreyHead
Hi renierjvr,

This sounds as if the form is being submitted more than once - possibly a problem with SEF URLs. Does it work if you use the default ChronoForms URL to load the form?

Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
A
Alistair
I'm also having this issue, baiscally I removed the image field from the basic demo contact form, but when sending the form it still requires an image to be chosen apparently, as it gives the error "You didn't select the correct image.". I'm running Chronoforms6 on Joomla 3.8.13.
GreyHead
Hi,
I've seen a couple of reports recently where there seems to be something odd happening with the Joomla Router + ChronoForms. In these cases setting the form action URL manually seems to have fixed the problem e.g. https://domain_name/index.php?option=com_chronoforms6&chronoform=form_name&event=submit
Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much