Buy Now
Sign in

Form with plugin not working with Joomla cache enabled

jj135 , July 20 2017

When I put a simple form in an article using the plugin it works fine with the Joomla cache disabled. But when I turn on the cache in the site settings (conservative) the form does niet work OK. After submitting I have the debugger active, When the cach is on and I relaod the page the debugger dat shows up again in stead of the form. This does niet happen when the Joomla cache is turned on.

Is this a bug?

CF6 & Joomla 3.7.1

Kind regards,
Hello jj135,
I'm not a Chrono professional, but after checking your new post, I think that the following links may help:
Why does Joomla! Cache stop my form working?
P.S: I'm just an automated service
I'm an automated service, my answers may help, but they may not be accurate.
Hi Jip,

It is the normal behaviour of the Joomla! cache. If the version of the page that is cached includes the DeBugger data that is what you will see when you re-load the page.

Note that some of the Captcha checks may not work with Caching enabled as they rely on a newly generated key code.

ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
I tried this in the custom code:

$cache = JFactory::getCache('com_chronoforms');

But when I do this and the cache is turned on the form won't submit.

I also tried using a module position and the Chronoforms module is stead of the plugin, But that also does not work.

Any thoughts?

Kind regards,
Hi Jip,

I really don't know enough about Joomla! caching to be sure but I suspect that it is the article cache that is the problem not the ChronoForms one.

ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
But will this work OK when submitting the form? So this is only a 'problem' with the debugger data?
Yes, I think this is the article (joomla) caching. Juist trying to figure out what works and what not ;-) Thanks!
In my opinion the normal mode of joomla is caching switched "on" ... every plugin as far as I know and as far as I use works with that setting without any problems ... so why does ChronoForms can't work with caching switched on ???
Hi Main,

It depends, caching should work fine if the content is static and does not change, but since the form processing is dynamic then caching may disable some of the form features, so if you decide to use the form inside a cached content item using the plugin then you will need to set the "action url" to {url:submit} in order to send the form to a non cached page.

Best regards
If your main question got answered then please mark the answer using the button!​
​Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
Why does nearly every other form system work with Joomla cache enabled with out needing to do anything custom and Chronoforms does not?
With caching enabled I get no javascript and CSS added to the forms.

​It's making very hard to use over other form systems that work.​
​Could you make a system version of the plugin as they seem to work better with cache based with RSform plugins.
Edit: So i had some spare time so I decide to make a version based on the RSForms System plugin and initial testing looks to make it work better. Just need to do some more testing to see how it works.