Buy Now
Sign in

Chronoform 6 not getting emails

Emina_bb , June 14 2017
E
Emina_bb
Dear all,

since I´m new to Joomla and Chronoforms.. I´m having little trouble setting it all up!
I made a form in the new Chornoform 6 and it all looks really nice.. when you feel it out there is a nice thank you msg and everything is fine.. till we get to the email story. I have set it up like this;

went under SETUP

Email


Designer Label : left it empty
button enabled: is blue so it is enabled
Recipient list: emha@blond-braun.at
Subject: Job application
Auto fields data: I have enabled it
Body: <wrapper><h2>Job application</h2></wrapper>
<container>
<row>
<column first last>
{section/template:one}
</column>
</row>
</container>
Send as: HTML
Auto attach fiel: enabled
Attachment list: Curriculum vitae, service certificate, documents
Send settings
Reply email: emha@blond-braun.at
Reply name: Blond & Braun
From email: office@blond-braun.at
From name: Blond & Braun

I know this may be silly to some of you but I´m trying to make it work for a few days...
pls Help!
GreyHead
Hi Emina_bb ,

This looks OK apart from the Attachments which I think should have the corresponding input names,

Please drag a Debugger action into the On Submit event, then submit the form and post the debug - including the 'dummy emails' results here.

Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
E
Emina_bb
Dear Bob this is what came out... :/
Array
(
[chronoform] => emha
[event] => submit
[Bewerbung_als] => q
[title] => Frau
[Vorname] => emina
[Nachname] => kusuran
[email] => eminakusuran@hotmail.com
[Bewerbung] => jejeje
[Lebenslauf] => ew_50years_Blues_RGB(1).jpg
[Dienstzeugnis] => ew_50years_Jazz_RGB.jpg
[Unterlagen] =>
[secicon8] => 5943b2e831756
[button7] =>
[29313f16028f017257a2de3acd1225af] => de-DE
[_ga] => GA1.2.1624315662.1496309104
[__utma] => 204800195.1624315662.1496309104.1497431937.1497431937.1
[__utmz] => 204800195.1497431937.1.1.utmcsr=(direct)|utmccn=(direct)|utmcmd=(none)
[3f1d3717687cb61601f541ac8b7a0d76] => 3963922e3927dcaffd90fa5747c18c44
[_gid] => GA1.2.587954695.1497592797
[09809fd79d5f0b95a2ce56b9b6686749] => 91497fdf027a411ad7d09348ca1e4cc2
[cmobile] =>
[language] => de-DE
[Itemid] => 321
[option] => com_content
[lang] => de-DE
[view] => article
[id] => 110
[emha] =>
)

Array
(
[check_secicon6] => Array
(
[_success] => The security image verification was successfull.
[var] => 1
)

[email2] => Array
(
[recipients] => Array
(
[0] => emha@blond-braun.at
)

[subject] => Online Job Bewerbung
[body] => <wrapper><h2>Online Job Bewerbung</h2></wrapper>
<container>
<row>
<column first last>
<table width="100%" cellpadding="3" cellspacing="3" border="0" class="ui table">
<tr><td width="30%" valign="top" align="right"><strong>Bewerbung als</strong></td><td width="70%" valign="top" align="left"></td></tr>
<tr><td width="30%" valign="top" align="right"><strong>Title</strong></td><td width="70%" valign="top" align="left">Frau</td></tr>
<tr><td width="30%" valign="top" align="right"><strong>Vorname</strong></td><td width="70%" valign="top" align="left">emina</td></tr>
<tr><td width="30%" valign="top" align="right"><strong>Nachname</strong></td><td width="70%" valign="top" align="left">kusuran</td></tr>

<tr><td width="30%" valign="top" align="right"><strong>Email </strong></td><td width="70%" valign="top" align="left">eminakusuran@hotmail.com</td></tr>
<tr><td width="30%" valign="top" align="right"><strong>Bewerbung</strong></td><td width="70%" valign="top" align="left">jejeje</td></tr>
<tr><td width="30%" valign="top" align="right"><strong>Lebenslauf</strong></td><td width="70%" valign="top" align="left">ew_50years_Blues_RGB(1).jpg</td></tr>
<tr><td width="30%" valign="top" align="right"><strong>Dienstzeugnis</strong></td><td width="70%" valign="top" align="left">ew_50years_Jazz_RGB.jpg</td></tr>
<tr><td width="30%" valign="top" align="right"><strong>Unterlagen</strong></td><td width="70%" valign="top" align="left"></td></tr>
</table>
</column>
</row>
</container>
[files] => Array
(
[0] => Lebenslauf, Dienstzeugnis, Unterlagen
)

[from_name] => Blond & Braun
[from_email] => office@blond-braun.at
[reply_name] => Blond & Braun
[reply_email] => emha@blond-braun.at
[result] => the Mail could not be sent.
[var] =>
)

)
admin
Hi Emina,

The domain on which you are testing this is blond-braun.at ? if not then this may be the reason, you may also try to clear the "reply" name and email fields, does this make a difference ?

The debug result is that "the Mail could not be sent.", which means that there is a problem some where.

Best regards,
Max
Max
If your main question got answered then please mark the answer using the button!​
​Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
E
Emina_bb
Hello dear all,

I have tried to clear it all it still doesnt send emails -.- the debugger still says that the Mail could not be sent..
I saw now that the event loader ist red and stands fail..

In the setup after the security image ist a field I can´t delete and it just stands red and fail..
admin
Hi Emina,

As per the debug in the email, you did not have "from name" in your email and this may be why it does not send at the moment.

Please post a screenshot of the fields you have a problem with.

Best regards,
Max
Max
If your main question got answered then please mark the answer using the button!​
​Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
E
Emina_bb
I´m gonna send it per email thanks for your time
E
Emina_bb
Der Max,

I got the form to send emails, dont ask me how haha

the only thing now is that the form is not sending the elements in the email to me that I upload..
You can see my settings in the attachment.

Best wishes,
Emina
Attachments
fields.jpg
fields.jpg
(336.67 KiB)
327 Downloads/Views
field_2.jpg
field_2.jpg
(307.52 KiB)
476 Downloads/Views
field_3.jpg
field_3.jpg
(287.45 KiB)
330 Downloads/Views
admin
Hi Emina,

The field name should not have the square brackets around it [], please remove that and update the settings in the upload action too.

The files are uploaded to the server or not uploaded ?

Best regards,
Max
Max
If your main question got answered then please mark the answer using the button!​
​Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
GreyHead
Hi crops315,
This sounds like the form I looked at an hour or two ago. The problem there was a repeated address in the BCC box of the email. Apparently that gave the Joomla mailer indigestion.
Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much