Buy Now
Sign in

ChronoForms 6 recaptcha (no captcha) passing the test but showing error: You didn't pass the NoCaptcha verification

stanley918 , June 02 2017
Answered
S
stanley918
Hi!
"Security image" failed to stop spam on my site and I tried recaptcha (no captcha).
Now, recaptcha verification is passing (green check), but form is not sent and I see the error: "You didn't pass the NoCaptcha verification".
Please, help.
The content here is visible only for authorized users.
admin
Hi stanley,

Do you have the latest update installed ?

Did you provide the secret key in the check google recaptcha action ?

Best regards,
Max
Max
If your main question got answered then please mark the answer using the button!​
​Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
S
stanley918
Of course: ChronoForms 6.0.5, and I provided key on setup tab in simply mode.
ReCaptcha works normally on site (with system plugin).
Attachments
recaptcha_key.jpg
recaptcha_key.jpg
(58 KiB)
1471 Downloads/Views
admin
Hi stanley,

Please send me a message using the contact us page and I will give you a patch file which "may" fix the issue.

Best regards,
Max
Max
If your main question got answered then please mark the answer using the button!​
​Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
K
kakau
I have the same problem. Please send me patch file.

Best regards
Karl
N
nathan
Hi,

I'm also running Chronoforms 6.0.5 with a ReCaptcha. I've entered the site key in the field designer, and the private key in the Feature Setup.

I see the Captcha in the form, can click on it (green check) and then receive the same error message: "You didn't pass the NoCaptcha verification".

In short, same problem. Thanks for any insight!
admin
Hi,

Please send a message using the contact us page if you need the patch file.

Best regards,
Max
Max
If your main question got answered then please mark the answer using the button!​
​Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
C
coulling
When is the new release coming out with this patch?
admin
Hi coulling,

no date set yet, please send me a message using the contact us page and I will send you the patch file to test.

Best regards,
Max
Max
If your main question got answered then please mark the answer using the button!​
​Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
C
coulling
Sent
S
stanley918
patch did not solve the problem
admin
Hi,

Could you please add a debugger action in the "fail" event of the Google nocaptcha and post the debug results ?

Best regards,
Max
Max
If your main question got answered then please mark the answer using the button!​
​Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
S
stanley918
I gave you admin access, is this not enough?
M
Minnie Mouse
lol!! i had this happening. then went into my plugins and recaptcha was disabled. turned it on and added the keys. everything is working now. make sure your joomla plugin is enabled!!

then it also needed a redirect. not just a message....
S
stanley918
lol/ no lol, but problem has solved.
Trouble was in reCAPTCHA keys, I think that I just has got confused in it.
Site key in Google NoCaptcha field on Designer tab mean Public reCAPTCHA key.
Or may be I did not clear cache after applying the patch, or may be cosmic rays.
Thanks for all!
B
bart@exponent.be
Hi
I have the same problem here. Can u send me the patch file?


Thanks
Bart
Attachments
chrono-error.png
chrono-error.png
(19.46 KiB)
1065 Downloads/Views
GreyHead
Hi Bart,

If you have the current version of CFv6 that will include the patch as this thread is from some time ago.

Please check that you have the correct Google keys set.

Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
B
bart@exponent.be
Thanks Bob!
The problem was Yootheme Pro. Chronoforms webform should be first placed in a module and then put in Yootheme Builder via the module element and not via the HTML element.
C
coughlin
I'm having the same issue as the OP but in CFv5. Is there a patch or solution available for v5 or is the only fix to update to v6?

I have checked site keys, made sure plugin was enabled, am not using YooTheme Pro. Was working fine yesterday, no changes were made on the site but now it's not working today.
GreyHead
Hi coughlin,

You won't have the same problem as you are using a different version of ChronoForms. Clearly something changed on your site since yesterday. Does the form submit from the Test Form or View Form links?

Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much