Buy Now
Sign in

Max Execution Error When Form Gets Large

ausfiero , June 02 2017
A
ausfiero
I have discovered a huge problem. Once your form gets rather large a server with a standard 30 second timeout limit will not load the form editor and I get the dreaded Fatal error: Maximum execution time of 30 seconds exceeded in /XXXX/XXXX/public_html/libraries/cegcore2/helpers/data_loader.php on line 72

Even on small forms the component seems to really battle to load forms. I didn't have this problem with 5.

Also I cannot set the execution time higher because as with most shared servers it is set at server level and cannot be changed with a custom php.ini file.
admin
Hi Ausfiero,

I will try to have a solution to this issue in the next update, but many users have long forms and the problem did not arise.

What is the number in the red box beside the preview button in your form edit screen ?

Best regards,
Max
Max
If your main question got answered then please mark the answer using the button!​
​Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
A
ausfiero
Strangely enough 1 form got to 3800 with no problems. The current on that will no longer open is 3208.
A
ausfiero
The first one was before the .05 update. The latter after if that helps.
admin
Hi ausfiero,

Please take a backup of the non working form and send it to me using the contact page.

Best regards,
Max
Max
If your main question got answered then please mark the answer using the button!​
​Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
A
ausfiero
Just checking you have got it.
A
ausfiero
Any updates on this?
admin
Hi Ausfiero,

I got it and replied earlier, he form link was broken, please upload the form backup file to Google drive and send me the link or just send it by email to: webmaster AT chronoengine DOT com

Best regards,
Max
Max
If your main question got answered then please mark the answer using the button!​
​Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
admin
Hi,

Both 6.0.6 and 5.0.16 should have fixed this issue.

Best regards,
Max
Max
If your main question got answered then please mark the answer using the button!​
​Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
G
gatoractiv
I am also having this same issue with a large, multi page form [Fatal error: Maximum execution time of 30 seconds exceeded in .../public_html/libraries/cegcore2/helpers/data_loader.phpon line192] I don't know where else to post this. Please help!
GreyHead
Hi gatoractiv,
Please check Max's post just before yours - do you have those versions (or later) on your site?
Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
G
gatoractiv
Yes, I have Chronoforms6 Administrator Component v 6.0.19 installed and I'm running Joomla 3.8.10.
healyhatman
Just increase the max_execution_time on your server
Web developer at SkySpider.com.au
I don't work for ChronoEngine but I do accept donations paypal.me/healyhatman
G
gatoractiv
Unfortunately, I am limited by my host (Hostgator) to the default. Even if I change the php.ini in my root folder, they have limited it in their php settings to 30 seconds.
PHP has been configured to use the following settings on our shared and reseller servers:​
​​
​safe mode = Off (cannot adjust)​
​memory_limit = 256M (MAXIMUM)​
​max_execution_time = 30 (MAXIMUM in seconds)​
​max_input_time = 60 (MAXIMUM in seconds)​
​post_max_size = 64M (MAXIMUM)​
​upload_max_filesize = 64M (MAXIMUM)​
​enable_dl = Off (cannot adjust)​
​​
​The above settings either CANNOT be changed or exceeded...
healyhatman
well then you're SOL, unless you break it up into seperate forms.
Web developer at SkySpider.com.au
I don't work for ChronoEngine but I do accept donations paypal.me/healyhatman
E
emmexx
I reported the same problem for me here https://www.chronoengine.com/forums/posts/t105854/wsod-loading-a-form-for-edit-and-timeout and it's getting worse over time.
Today I had to set max_execution_time = 300 and apache TimeOut = 300 in order to load my form.
I had to parse logs and change random (sort of) server parameters for hours before getting it loaded.
Last time I opened that form there was no timeout problem, max_execution_time was 150, TimeOut was set to its default value.
The record of the form doesn't seem too big to me: views + events + sections + functions account for about 200 KB, including html text.
My server is a standard Centos vps with a standard production configuration.
As I wrote in the other thread the problem probably arises in a str_replace call.
I believe this problem should be addressed as soon as possible.
bye
maxx