Buy Now
Sign in

Brand new users has some styling issues

trogladyte , January 25 2017
T
trogladyte
In the past have used Kunena but installed that and had enormous problems with styling for one. So searched and found ChronoForum - wow, very nice!

However, I have some issues with buttons on the forum - http://www.digitalguarddawg.com/component/chronoforums - currently this is a hidden menu item and I'm just starting to populate it with foums (the whole Category v Forum threw me for about 15 minutes till I figured out the logic to it - understandable now but not intuitive compared to everyone else's naming conventions).

The buttons in the main menu ribbon - Home, Unanswered, New, and Active have a white "veil" over them, which only 1/2 disappears on hover. Secondly, if you go into a forum, and then hover over the New Topic button it changes size which is undesirable behavior. I suspect it's my (Artisteer) template, and, perhaps, Bootstrap called by the forum (Artisteer doesn't play totally well with Bootstrap). I will be updating the template soon to something else (I now use TemplateCreatorCK - awesome product!!). But, right now, I need to get the forum running - matter of priorities.

The other question I have is how I have nested forums. So, I really wanted this:

PRODUCTS (a category)
- Automotive
-- PBS-I
-- PBS-II
-- iKEY
-- iKEY-RS
-Motorcycle
-- KIM-U
--KIM-SS

I don't see how I can do this as I can only assign Forums to Categories, but I can't have sub-categories; they're all top level.
T
trogladyte
Oh, a couple of other questions...

If a user is not logged in, is it possible to hide the "New Topic" button? And, how do I show the Login/Create an account links? I assume these are related to the forum and not to Joomla users?
T
trogladyte
OK - first annoyance with CF... Where is the edit post button? Basic and must-have requirement IMHO! I could have just edited my first post, whereas here I am posting a third post!

So, found where to disable New Topic when not enough permissions. Still nowhere within the forum page to login - why not? Like the Edit button... must-have!

So I log into the frontend and go to the forum. There's the New Topic button. Yay! But clicking it merely seems to refresh the page and does nothing else. I'm Super Admin of course so I should be able to post when logged in.
admin
Hi trogladyte,

The login/account links are handled by the Joomla users module, the forums extension doesn't have this, just like here on our website, you can find the links on the right side.

You are currently using v1 of the forums, and it has some limitations, currently v2 is almost ready for public release and it may solve some of the issues you have + it has the nested forums feature and easier interface, Please send me a message using the "Contact us" page and I will send you the installer by email.

Best regards,
Max
Max
If your main question got answered then please mark the answer using the button!​
​Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
T
trogladyte
Hey Max

Thanks for V2 - looking great!! Where have the buttons that I was having issues with - Home, Recent, Featured, etc? Are they removed in the new version? They are quite useful I have found when on forums.

Also, will editing of posts be available on V2 (as you see in a comment above, I ended up writing the initial post and 2 replies to get my questions across, whereas it would have been tidier to edit the initial post).

Thanks! Kunena has serious competition!!
admin
Hi trogladyte,

Glad you like it!

The filter buttons are in a dropdown under the "filter" icon at the top menu bar.

You can edit your posts if you give your user group the permissions to do so, its available in v1, but in v2 the permissions setup is just much easier.

Best regards,
Max
Max
If your main question got answered then please mark the answer using the button!​
​Please let us know if you have any problems with the new forums text editor, we appreciate your feedback!
T
trogladyte
Ah-ha OK thanks.