Buy Now
Sign in

Gateway Timeout

xtempore , January 17 2017
X
xtempore 15
January 17 2017 #364297
Just installed Chronoforms 5 and am struggling to make it work.

All I'm doing is a basic contact form, nothing fancy.

Whenever I submit it seems to just get caught in an infinite loop on the server which eventually returns a "Gateway Timeout" error.

Attached a screenshot of my Setup.

Any suggestions appreciated!
Attachments
chrono-prob.jpg
chrono-prob.jpg
(143.61 KiB)
128 Downloads/Views
GreyHead 63.3
January 18 2017 #364313
Hi xtempore,

The form setup looks fine. Please take a Form Backup using the icon in the Forms Manager and post it here I'll take a closer look.

Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
X
xtempore 15
January 18 2017 #364316
I solved the problem (sort of). It occurs when I use the entered name and email as the dynamic from name and email.

If these are blank, I get the Gateway Timeout.

I would like them to be optional, so that people can leave an anonymous message, but I also want them to be the from email when entered so that I can easily reply.

For now I just made the fields required.
GreyHead 63.3
January 18 2017 #364319
Hi xtempore,

I strongly recommend that you do *not* use the Dynamic From Email element in your Email Setups. Using this often results in your emails being marked as spam and dropped into a spam filter. Instead use the static From Email with an address that matches the site domain name and use Dynamic ReplyTo Email for the user email. The result is the same but with a much better chance of good delivery.

Bob
ChronoForms technical support
If you'd like to buy me a coffee or two, thank you very much
X
xtempore 15
January 18 2017 #364343
Great advice. Thanks very much.